CSI Camera Not Detected on Jetson Nano

I have the same problem as this person: CSI-Camera is not found on the Jetson Nano where my CSI camera is completely unrecognized on my jetson nano, however, the solution did not work for me.

I had this camera: https://www.amazon.ca/dp/B012V1HEP4?ref=ppx_yo2ov_dt_b_product_details&th=1 and I thought it was a driver problem because this camera is not on the list of supported cameras Jetson Partner Supported Cameras | NVIDIA Developer

So I bought this camera: https://www.amazon.ca/dp/B0B3XBQM9Z?psc=1&ref=ppx_yo2ov_dt_b_product_details which is on the list of supported cameras, however, I am still having the same problem.

hello decroosphil,

how you adapt the driver? the default release did not contain IMX519 sensor drivers,
please contact with sensor vendor for further supports.

Oh, the site of supported cameras said the drivers for those cameras were already included in the SDK, so I did not install any drivers yet, assuming it would work out of the box.

I tried following Arducam’s instructions at Quick-Start-Guide - Arducam Wiki and I ran into this error when installing the driver:
"Cannot find the corresponding deb package, please send the following information to support@arducam.com
Kernel version: …
Jetson type: … "
I am waiting on a reply from them at the moment to see if they have a solution.

Would you share full error logs?

there’s no IMX519 sensor drivers as you can see in the [Driver Package (BSP) Sources] package for linux-tegra-r3274 release version.

As per the response I got from Arducam support, the version of Jetpack that I was using did not support that camera, and they recommended I use a version as per this guide: Introduction to Arducam Jetson Cameras - Arducam Wiki

I opted to just get an IMX219 camera as that one should be natively supported, or at least installing the driver should be easier. Hopefully that one will work once it arrives.

hello decroosphil,

yes, Nano platform is by default support with Raspberry pi v2, imx219.
please see-also devloper guide, you may also running Jetson-IO utility to Configuring the CSI Connector if there’s a device tree overlay.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.