CUDA 2.0 Exceptions

The following issue was RESOLVED by re-installing the Vista 64 bit CUDA driver:

I am getting the following exceptions when I try to run the boxFilter project on Vista 64 in either debug or release modes:

First-chance exception at 0x779d649d in boxFilter.exe: Microsoft C++ exception: cudaError at memory location 0x0012f884…
First-chance exception at 0x779d649d in boxFilter.exe: Microsoft C++ exception: cudaError_enum at memory location 0x0012f7c8…

In debug mode, these exceptions cause the program to quit when the first line is hit:

CUT_DEVICE_INIT(argc, argv);

In release mode, the exceptions are hit every frame but the program runs and displays an image.

-Mark Granger

Which GPU are you using?

I have a 8800 GTX.

I am running a quad processor (2 dual core) AMD opteron 2GHZ computer with 4GB of RAM. System software is Vista Business 64 SP1 with all patches and updates.

-Mark Granger

I don’t think that any of the precompiled SDK examples are running. I am running the ones in this folder:

C:\Program Files (x86)\NVIDIA Corporation\NVIDIA CUDA SDK\bin\win64\Release

They have different problems depending which one I run. The fluidsD3D9.exe comes up with an image of random green dots (the starting image when this program runs normally). It repeatedly displays the following error (I presume onece per frame):

cufft: ERROR: D:/Bld/rel/gpgpu/toolkit/r2.0/cufft/src/, line 112

simpleD3D9.exe, Mandelbrot.exe and others appear to run but the window(s) are black. I can quit them normally.

simpleTexture.exe and others crash.

particles.exe runs and I can see the particles in the box and interact with it but I don’t think it is working correctly when I tell it to animate since nothing happens or they all disappear.

imageDenoising.exe runs and I see the original image but none of the modes changes the image.

I tried re-installing the SDK but got the same errors when I ran the samples.

-Mark Granger

All of these problems point to a problem with the driver installation.

I reinstalled the CUDA 2.0 Vista 64 bit driver and it now seems to be working correctly. I have a feeling I may have clicked the wrong button when asked if I wanted to install unsigned drivers when I first installed it late last night.

Thanks for your help.

-Mark Granger