CUDA Application not recognizing installed 9800GT

I am trying to track down a problem which has the following symptoms

#1 TMPGenc 4.0 XPress works fine, recognizes the CUDA enabled 9800GT and transcodes very quickly
#2 The CUDA SDK test binaries all run, and at speeds which are using CUDA
#3 The Lightning Hash Cracker from Elcomsoft runs on CUDA
#4 The Badaboom 1.1.0.132 supplied SysCheck sees the correct device and says its good, I can run the Badaboom
1.1.0.132 executable and it transcodes quickly
DirectX version number is: 9.000000c
You have 1 devices in your system.
Device 0:
GPU is: NVIDIA GeForce 9800 GT
GPU driver version number is: 185.849998
GPU system memory is: 1024 MB
Your system is configured properly for this application
#5 Cuda-Z sees the 9800GT fine

However
#A If I try to install Badaboom 1.1.1.194 the install fails with a “Your system is not compatible with Badaboom. You must have a CUDA capable Nvidia Card and Driver to use Badaboom. See details by running Syscheck from the start menu” Of course since the install has failed you cannot run the SysCheck supplied with the executable :(

#B I can install trial ElcomSoft Distributed Password and the agent runs fine, but it never “sees” the gpu and always runs on the dual cores. However if I run the GPU Manager supplied with this package it “sees” the 9800GT gpu fine.

OS: WinXP SP3
Mobo: ASUS M2N-MX SE Plus running latest 0602 BIOS
CPU: AMD Athlon 64 X2 4400+
GPU: Inno3D 9800GT w/1GB in the PCI Express x16 slot (its version 1.0 PCIe)
Nvidia: NVIDIA Driver for Windows XP 32-bit 185.85
PSU: Vantec ion 800W

The Mobo has a built in Gforce 6100 that cannot be disabled. In the BIOS you can select between the priority of the 3 different possible devices - PCIe->PCI->IGP or IGP->PCI->PCIe. If you set it to the former, with PCIe (9800) as the high priority then the IGP (6100) does not show up in the Device Manager, if you use the latter priority, with the IGP (6100) as the high priority then both devices show up in Device Manager and can both be run with the 185.85 Nvidia driver (I’ve tried both setups to no avail)

Bottom line is I want to run the Elcomsoft software on the GPU - but it seems that it is not “detected”, while TMPGenc has no issue. How do CUDA applications tell whether there is a gpu they can use? Is there some standard way to force the application to use the gpu?

I’m having the same error. I have two 260’s and a 7900 installed.

I’m probably guessing that its seeing I have a 7900 and just goes retarded and stops stops the install.

I’m going to disable the 7900 from the device manager to see if that does anything.

I also should have PCI-e x16 selected as default, but I’ll have to check.

I definitely want to figure this out.

Encoding on an i7 920 @ 3.38 takes 45 minutes to encode WMV, 2-passes, VBR (unrestrained), 1920x1080 resolution.

With all the prospects that I’ve read about using the GPU to power through encoding video, I want to get this working!

-Eric

– EDIT –
I was running under user-mode. Figures. It didn’t let the installation finish. Switched over to an administrator account and the installation went through.

tt doesn’t work under SLI mode. I’ll have to turn that off.

hi

did u try to update the drivers? 190.38 is the latest version.

Good luck