Cuda toolkit for jetson platform

hi all I am trying to compile tensorflow c ++ on my pc for jetson platform through qemu and docker container l4t. I noticed that although cuda 10.2 containers are available on ngc they are not properly installed or in any case do not contain the necessary cudnn libraries. So I tried to download and install them but on the nvidia site when I look for the version for arm it is not present but only x86 and power pc. Where can I download the cuda for arm?

Thanks in advance

CUDA for arm64 Jetsons is only available via the SDK Manager. You can tell SDKM to download only and not actually install anything. The reason this is useful is that the default download is to:

This means you can find the repo “.deb”, install that to your QEMU, and then install CUDA to your QEMU. I don’t really know if the apt-get mechanism works well from in QEMU, but the actual CUDA “.deb” should also be there in the downloads even if apt-get does not work correctly inside of QEMU (I’ve never tried from QEMU, but the “” script tends to imply it would work…in fact, it might be good to study if you are interested in details).