Currents backflowing with USB3.0 ports, Jetson Nano B01

It seems one of my B01 is having problems with power circuit.
I guess any terminal regulator or something like that on board are broken phisically.

When I connect any USB device with USB3.0 ports, power LED on JetsonNano starts blinking and also get overcurrent warning on GUI.
Even clearly not using power so much from USB ports.
(It starts blinking around 0.6A~ in total with USB3.0 ports)
Sometimes that cause system shut down(blackout).
I tried both barrel jack or microusb, but had same issue at all. 10W mode or 5W mode also didn’t matter.
Voltages were enough (around 5.1V).
USB connectors, include microUSB and barrel jack are not broken, at least seems OK, also solderings are fine.

Then I connect USB device and power bank using Y-cable into USB3.0 port, with USB current tester.
I found currents were backflowing onto USB3.0 ports, and LED stop blinking, system being stable during the power bank was connected to USB3.0 ports with USB devices using Y-cable.

I’d like to ask replacement request, thank you.

I can’t answer, but I highly recommend viewing this video on the topic of “backfeeding”:
(Or the YouTube URL

1 Like

Thanks for your reply, I checked your recommended video.

I could understand a little about backfeeding and measured Voltage lines again.
Then I could find main input Voltage were not enough, that was under 5V, around 4.97V when it’s running processes.
Replaced the powering source with another one and completely solved.

So sorry and thank you so much again for your advice!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.