Dell R730 with Grid K1 error

I’m having a problem with a the new R730 box with the K1 cards. I disable the MMIO above 4gb in the bios. The boot stops with an error UEFI0134 Unable to allocate Memory Mapped Input Output (MMIO) resources for one or more PCIe devices because of insufficient MMIO memory.

I also have a R720 box with K1 cards and that works just fine.

I have the latest bios upgrade 1.1.4

This fix will likely come in the form of a bios update from the Vendor in order to fix the Memory mapping issues on post. If you are using a x64 OS, can try and enable above 4G encoding.


Which hypervisor are you trying to use?

I’m using XenServer 6.2. Enabling the 4G eliminates the error on startup, but XenServer does like it and won’t recognize the K1 cards.

Hi Gary,
XenServer 6.5 supports MMIO +4GB. You will need a license to activate the GPU tab in XS 6.5 but it is enough for testing purposes if you can connect to a Citrix licensing server with an evaluation license added.

I just noticed that 6.5 came out and it’s resolved the MMIO issues. Thanks for all your input and help.


You need Enterprise Edition, though a XenDesktop license will do the job as XS is included in that.

If you don’t have XenDesktop, ask Citrix for an evaluation license.