Development Board Does Not Boot

Hi there,

I was excited to get the jetson-tx2 board today. However, when it is powered up, nothing happends.

  • LED CR1, CR2, CR5, and CR6 on.
  • TX2 moudle fan off.
  • No HDMI output.
  • Indicators on ethernet port off / No ethernet activity.

I tried to flash the system, following the instructions from

The flashing DID succeed. But it changed nothing.

Did anyone have the same issue and would you please help?

Thanks & Cheers.

I got it booted. Sorry to bother you guys.

I unpluged the HDMI cable, and the ethernet worked! At least now I have access to the board. I will try to figure out how to make the display and gpu work.

there is same trouble as you. do you solve this problem? thks

It is important to know that video not showing up is often just a video configuration issue and the Jetson is otherwise actually running. The fan does not turn on unless the system is under load…normally there isn’t enough heat being generated for the fan to turn on. The red LEDs near the heatsink and near the PCIe slot indicate power is present…don’t let the red color fool you into thinking it is “bad” (the LEDs in fact confirm power is present). If you can ping the Jetson, or see a router log where a DHCP request was granted an IP address, then you will know it is just a video issue.