Cannot boot up Jetson TX2

When I press and release the power button, the screen cannot detect the TX2. I was connecting with an HDMI to VGA cable. The fan does not run as well. There are 4 LEDs that are on, CR1 and CR2 are green, CR6 and CR5 are red.
I tried to put it into recovery mode and flash the TX2 with the latest jetpack, but it doesn’t allow me to continue installing the SDK components because it cannot connect over ssh. I used “nvidia” as both user name and password and it doesn’t work. I tried ping on the host machine, and it works.
The issues remain the same after re-flashing. What should I do?

The fan does not normally run unless there is enough heat to need it. During normal use the fan will typically never run. Fan behavior is normal.

Depending on carrier board model you may have red LED for indication of power to the module, and another for power to PCIe. The two green LEDs indicate normal operation. LEDs seem normal.

VGA will cause failure and is not supported. Some people can get VGA to work, but there are setup issues you would have to understand, and not all VGA monitors can work. HDMI has a DDC wire, and the DDC wire is used for the video card to query the monitor for its capabilities (EDID data). This adds plug-n-play abilities. Without this wire VGA has no hope of telling the video card what modes it has available. The integrated GPU (iGPU) of the Jetson does not accept modes other than those reported via the EDID data.

You will not be able to ssh until the first login is completed and the account/password is created (older distributions had this built in, newer distributions add this information on first boot with a local keyboard/monitor).

If you have a monitor which reports EDID (HDMI, DisplayPort, DVI-D), then you could do the first boot with that. Or perhaps via serial console. After this ssh should work. Whether or not the particular VGA monitor can be made useful depends on how much patience you have (it is recommended to use a non-VGA monitor).

Thanks, now it all makes sense