Disable dithering on RTX A4000?

Hello,

I have a Nvidia RTX A4000 and by default after a fresh driver installation the driver is auto enabling temporal dithering by default as reported by the program Color Control. I have a true 8bit monitor and 10bit monitor and the drivers are trying to force the GPU into temporal mode by default. I also used a lossless capture card DVI2PCIe to capture the GPU output in the BIOS screen and the GPU is not using any dithering in the BIOS but once i install the drivers they auto set the card in temporal dithering mode. Is there a way to completely disable all dithering modes in Windows with a NVWMI script in Windows?

Hi @jakc9000, welcoem back.

As far as I could find out so far there is no tool as such to control that, possibly through NVAPI, but that information could be outdated.

Could you share your setup details? Like the Windows system info including

  • CPU
  • Motherboard
  • Exact OS version
  • Exact display names
  • how are the displays connected (which outputs, both 8 and 10 bit at once or seperately, …)

Then I can give that info to our display people and check what might be going on and what to do about it.

Thanks!

Hi, my setup details are:

  • Intel Xeon W-3175X
  • EVGA SR-3 Dark
  • Windows 10 LTSC 2021 and 2019 dual boot
  • Dell UP2720Q
  • Displayport to one monitor, in both 10 bit mode and 8 bit mode the drivers default to enabling temporal dithering mode.

Thanks that would be great i really appreciate it.

Hi jakc9000, can you tell us which explicit driver version you see this with? also, in our control panel, you can store the information shown in the topology viewer to a file, can you attach here/send that as well pls?
thanks
-Frank

and pls can you clarify: you got 2x DIFFERENT screens attached, one being limited to 8bit per color, but the other, the UP2720Q, being capable of 10bit? Is the problem also present, when having ONLY the 10bpc capable screen attached? Can you pls send screenshots of our control panel, the change resolutions tab, per each screen, pls? thanks
-Frank

There is also a very comprehensive Customer Help article about how to correctly set up 10bit or “Deep Color” support from within the NVIDIA control panel. Please check it out:
How to enable 30-bit color/10-bit per color on Quadro/GeForce?

Is there any update on this ti disable temporal dithering?. it seems there is no driver option on windows to disable it?

1 Like

Hi @tanselhalic, welcome to the NVIDIA developer forums.

This is not a configurable option as such in any OS control panel settings, no. Please check the Customer Help article I linked above for the necessary details and settings.

Thank you @MarkusHoHo I’ve noticed that the A4000 consistently applies dithering, irrespective of the color output bit, as detected by the frame-by-frame analysis using an output capture device. This tendency might contribute to eye strain, particularly in stereo applications where the human eye is sensitive. I’m curious whether there’s a way to disable this feature through any Windows regsitry settings or NVAPI.

1 Like

Hi I’m also having issues with temporal dithering even with setting up Nvidia control panel correctly. It seems that turing rtx4000 does not do that but now that I upgraded to the a4000 GPU it dithers no matter what. Can we please get a fix? This new a4000 I cannot use due to how bad it causes eye strain and other neurologic issues. Dithering is not a healthy thing to leave enabled and there’s no way to turn it off!! Please help. Thanks.

1 Like

Hello, im using the latest driver but have tried several older versions just to be sure it was not the latest driver causing the dithering. I’m only using one single Dell UP2720Q true 10bit panel which doesnt need dithering but for some reason the A4000 is still deciding to dither. On such a panel the fuzzy dithering algorithm is very noticeable and completely takes away image fidelity. With my older Quadro K4200 i do not get any dithering applied verified by the lossless capture card DVI2PCIe.

I have also tried the advice mentioned here but this did not change the results. How to enable 30-bit color/10-bit per color on Quadro/GeForce?

Can we please get a driver fix? Or any sort of additional help to fix this?

Also here is the topology file attached
NVIDIA System Information 03-04-2024 14-38-08.txt (3.6 KB)

Also by default Nvidia’s drivers are still enabling dithering even when these settings are set to 30bit/8bpc in the Nvidia control panel. Im using an application called VideoDiff which was designed to detect dithering patterns from recorded lossless files, and unless you disable dithering with a program called Color Control it still gets enabled by default after fresh driver installation. Even with these settings disabled the A4000 has a level of dithering that the operating system cannot interact with or has some form of aggressive compression being utilized in the GPU which makes the image fidelity just poor in comparison with a Turing based Quadro RTX 5000 or Kepler Quadro K4200. I suspect maybe thats how Nvidia created such a power efficient card. I will be testing an A5000 soon to see if it exhibits similar behavior.

Non-disabling aggressive dithering is a problem with all RTX 2000/3000/4000 series graphics cards. There are only two solutions. (1) Use a second video card (for image output) / combination of Radeon + Nvidia. Because when installing the driver for Quadro RTX A4000, you will have to uninstall the (old) one for Quadro K4200. Drivers for different generations of Nvidia will not work together. (2) Output the image through the iGPU. Set “high performance NVIDIA processor” for Quadro RTX A4000.