Display manager gets destroyed after reboot

Continuing the discussion from Unable to get / keep display with HDMI:

Please provide the following info (check/uncheck the boxes after creating this topic):
Software Version
DRIVE OS Linux 5.2.6
DRIVE OS Linux 5.2.6 and DriveWorks 4.0
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version

Target Operating System

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)

SDK Manager Version

Host Machine Version
native Ubuntu 18.04

I have tried all the methods in the forum but I can’t seem to find any solution.
I have tried both

  • lightdm
  • gdm3

both the managers work when freshly installed but after a day of running when the system is rebooted the display manager configurations are deleted (/etc/lightdm & /etc/gdm3) and I cannot get the display manager running gain via systemctl restart. Could anyone give me a decent solution ?

Dear @anil-kumar.chavali,
If the system is continuously on, you don’t see the issue? or you see the issue after a day of running and persists even after reboot.

display manager configurations are deleted (/etc/lightdm & /etc/gdm3)

It means, you don’t see lightdm or gdm folder at all when you see this issue? Heard from couple of customer on display issue but I could not reproduce the issue with couple of reboot immediately after flash or after a day. I need to check if all have this same symptom deleted files when they hit the issue.

Dear @SivaRamaKrishnaNV

If the system is continuously on, you don’t see the issue?

No indeed, if the system remains on I don’t face any problem.
The issue happens on only reboot , but after a ~12 hrs .

If I flash and then reboot the system multiple times within a shorter time frame there is no problem for the Display manager.

Its only after an overnight period , if the Nvidia drive is power cycled , the display mangers get killed and configs are deleted.

Dear @SivaRamaKrishnaNV

Any updates ?

Could you please provide us with detailed steps on how to reproduce this issue on our end? It would be helpful if you could share the exact commands you are using, including the commands to reboot the system. This will enable us to replicate the problem and provide you with a solution.

Hello @VickNV and @SivaRamaKrishnaNV

The steps I have followed to flash the Nvidia Drive Pegasus are in this link : Install DRIVE with SDK Manager :: DRIVE Platform Installation Guide with NVIDIA SDK Manager


  • I have flashed drive OS with ROS samples option enabled.
  • I have opted to clear persistent memory , else the display manger doesn’t work later.

To install the display manager I followed the steps linked under the finalize system section: Installing GUI on target

Once these processes are done if I immediately reboot the Drive via a terminal

sudo reboot

the system is works fine but after approximately a day if the same command is excuted , the display manager is destroyed.

The same happens even if I switch off and on the using the power button on the power supply of the Drive.

Dear @anil-kumar.chavali,
When I try to run sudo reboot on Tegra B directly, I lost access to Tegra and have to do tegrareset x2 on aurix console to get access back.
I issued poweroff/poweron command from aurix to restart the target and noticed no issue with display manager

nvidia@tegra-ubuntu:~$ systemctl status display-manager
▒● gdm.service - GNOME Display Manager
Loaded: loaded (/lib/systemd/system/gdm.service; static; vendor preset: enabl
Active: active (running) since Wed 2023-05-03 17:11:27 IST; 3min 48s ago
Process: 910 ExecStartPre=/usr/share/gdm/generate-config (code=exited, status=
Main PID: 928 (gdm3)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/gdm.service
▒└▒─928 /usr/sbin/gdm3
May 03 17:11:27 tegra-ubuntu systemd[1]: Starting GNOME Display Manager…
May 03 17:11:27 tegra-ubuntu systemd[1]: Started GNOME Display Manager.
May 03 17:11:27 tegra-ubuntu gdm-autologin][964]: gkr-pam: no password is availa
May 03 17:11:27 tegra-ubuntu gdm-autologin][964]: pam_unix(gdm-autologin:session

Dear @SivaRamaKrishnaNV

The issue you faced with tegraB seems to be another problem unrelated to mine. I don’t loose access to tegra B , I only loose the display after an overnight period (leaving it powered on). What I notice is that if I copied any ssh keys , they get deleted on the tegra as well, but no other access issues.

I did try the commands on the aurix but it doesn’t seem to help. Kindly let me know if you have any other leads.


Hello @SivaRamaKrishnaNV @VickNV

After multiple trials and tests, I managed to find the root cause its due to

sudo apt-get upgrade

By default the Ubunutu software updater is set to download and install security updates daily. This explains why I was only seeing issues after an overnight period. I still don’t know why things go awry when an security upgrade is done, and would request Nvidia to investigate.

For those looking to solve this issue :

After gdm3/lightdm install , go to the software updater settings as shown below:


Once the settings window opens from change the default settings to the one shown below:

For now not installing the upgrades works , so don’t install the security/recommended upgrades.

Dear @anil-kumar.chavali,
Thank you for sharing your insights on this.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.