Does TX2 support HDMI 4K60fps?

I’ve heard TX2 support HDMI 4k60fps, but in my case HDMI only support 4K30fps. My SDK version is 28.2.1.

nvidia@tegra-ubuntu:~$ xrandr
Screen 0: minimum 8 x 8, current 3840 x 2160, maximum 32767 x 32767
HDMI-0 connected primary 3840x2160+0+0 (normal left inverted right x axis y axis) 710mm x 400mm
3840x2160 30.00*+ 29.97 25.00 24.00 23.98
1920x1080 60.00 59.95 50.00 30.00 29.97 25.00 24.00 23.98
1280x720 60.00 59.94 50.00
720x576 50.00
720x480 59.94
640x480 59.94 59.94


It is probably because your 4k@60 mode is not a CEA mode so our driver filters it out.
Please try with other monitors too.

Connected to the same monitor, TX1 can output 4K @ 60fps. Is there any difference in the driver of this system


Please upgrade to rel-32.3.1 for both TX1 and TX2 and see if TX1 still can see the 4K@60 mode.
They are using different kernel driver pipeline.
Actually, rel-28.2.1 has lots of bug about mode selection. If you could see some modes in TX1 but not in TX2, I would say it is just lucky. TX1 does not officially supports 4K@60 if you checked the software feature in our document.

As for the debug in TX2, you could enable more verbose log in xorg by below guidance.

Add below option in /etc/X11/xorg.conf, 'Section "Device"'. Verbose mode logging will be shown in /var/log/Xorg.0.log
Section "Device"
  Option   "ModeDebug"

If you don’t see 4k@60 is showing up in xorg.0.log after enabling verbose log, it probably means the kernel filters it out.

Actually, 4K @ 60 mode was our customers needed. Our machine has burned rel-28.2.1. So we can only update the kernel to fix it.


I don’t get your purpose here.

So we can only update the kernel to fix it

So what do you want to modify?
It is better to check this step by step. Follow the method in my previous comment to check whether userspace Xorg driver really doesn’t get the 4k modes or not.

If it does not have 4k@60 mode, then please go to kernel driver source and dump the mode information there. Probably the mode filter function to see if 4k@60 modes are being rejected.

I’ve got debug log as follow, please check it.
hdmi_debug.log (157.6 KB)

According to the log, the only 4k mode the Xorg driver received is 4k@30. There is no 4k@60 mode.
Thus, it is as expectation that the kernel driver filters it out. You could check the kernel driver hdmi2.0.c for the mode filter function to see why 4k@60 mode got filtered out.

[     9.491] (II) NVIDIA(GPU-0):   Validating Mode "3840x2160_30":
[     9.491] (II) NVIDIA(GPU-0):     Mode Sources: NVIDIA Predefined, EDID, CEA
[     9.491] (II) NVIDIA(GPU-0):     3840 x 2160 @ 30 Hz
[     9.491] (II) NVIDIA(GPU-0):       Pixel Clock      : 297.00 MHz
[     9.491] (II) NVIDIA(GPU-0):       HRes, HSyncStart : 3840, 4016
[     9.491] (II) NVIDIA(GPU-0):       HSyncEnd, HTotal : 4104, 4400
[     9.491] (II) NVIDIA(GPU-0):       VRes, VSyncStart : 2160, 2168
[     9.491] (II) NVIDIA(GPU-0):       VSyncEnd, VTotal : 2178, 2250
[     9.491] (II) NVIDIA(GPU-0):       H/V Polarity     : +/+
[     9.491] (II) NVIDIA(GPU-0):     Mode "3840x2160_30" is valid.
[     9.491] (II) NVIDIA(GPU-0):