DrivePX2 AutoCruise: Network Setup does not work

Hi,
I am struggling to do the correct network setup between my host and DrivePX2 target
AutoCruise with Driveworks 1.2.400 and Drive 5.0.10.3:

On my host - Ubuntu 16, nvidia driver 396.82, cuda 9.2.148, driveworks 1.2.400, and sdkmanager 1.2.0.6738 -
I have a Nic named eno1 connected to Internet
and a StarTech USB-to-Ethernet adapter plugged into the host’s USB slot and configured according to the
documentation

in the hosts /etc/network/interfaces file as
#NIC
auto eno1
iface eno1 inet dhcp

#USB-to-Ethernet
auto enx005b
allow-hotplug enx005b 
iface enx005b inet static
    address 10.0.0.1
    netmask 255.255.255.0
    post-up /etc/init.d/isc-dhcp-server restart

So I am able to ping the connected AutoCruise platform at 10.0.0.1.

On the other side the AutoCruise ifconfig call comes up with
eth0 - but with an ipv6 address.
Is this the correct outcome?

If so, how does this match with the sample settings in the host’s
/usr/local/driveworks/samples/cmake/UploadVibrante.cmake,
which configures a make upload call using
VIBRANTE_HOST=192.168.10.10
VIBRANTE_USER=nvidia
which would result in an
scp call to nvidia@192.168.10.10 ?

A following question is, why I cannot ssh - and hence scp - to 10.0.0.1?
If I try to do ssh nvidia@10.0.0.1 even as sudo,
I am asked for the credentials (nvidia) but the connection request ends with a
"permission denied"

Can someone please give me an advice, how to do the networking setup right,
so that I can upload my cross-compiled code?
Thanks

Dear @hermann.fuerntratt,
You want to upload your DW compiled to target implicitly and trying to set up network settings to acheive that?

Yes, but it’s quite difficult, if the network ist not working and ssh seems to be tweaked as well…

Dear @hermann.fuerntratt,
ok. Is the board connected to internet. If so, could you share ifconfig output. If not, can you connect both host and target to network and get default IPs using DHCP and check using the same?
which would result in an
scp call to nvidia@192.168.10.10 ?

Yes. We need to set this as target IP eth0.

It looks like the whole problem comes from the fact, that the pristine P3407 system

  • does not have anything configured in /etc/network/interfaces

  • comes with an sshd_conf that has disabled password auth

I suppose mainly for security (ASIL?) reasons, so that I was not able to add my ssh key to the target, and hence ssh + rsync for sample software update via “make upload” was doomed to fail. Maybe you could add some more notes in the docs.

For now, I have added these items, and it works. Thanks for just beeing there and trying to help!
Best,
Hermann