Driver/CUDA install problems on Windows 7

I’ve got a laptop (MacBook Pro) running Windows 7 32bit (Boot Camp) and I’m trying to install CUDA 2.3. I’ve confitured the 9600M as the graphics chip.

When trying to install the driver cudadriver_2.3_winvista_32_190.38_general.exe I get the complaint that it could not find any drivers compatible with the hardware.

trying to install the 195.62_notebook_winvista_win7_32bit_international_whql.exe gives a dialog box error:

SetupNew\setup.cpp (138)
PAPP:
PVENDOR:
PGUID:
$14.0.0.162
@windows Vistat Service Pack 0 (7600) IE 8.0.7600.16385

I’ve tried installing the toolkit and SDK without the driver, but that seems to lead to more problems.

Any suggestions?

I’ve had the same issue, and I resolved it by modifying NVAO.INF file from 195.62_notebook_winvista_win7_32bit_international_whql.exe. I’ve included the modified file for you here. To resolve the issue:

  1. Replace the original NVAO.INF file by this one: http://www.box.net/shared/dt7svsl4g0
  2. Re-run setup. It should now execute without issues.

The file was tested and all CUDA samples work without any issues.

Will this work for windows 7 x64 ?

well I tried it with windows 7x64, doesn’t work. If anyone could post a fix for that, it would be awesome… it really sucks not being able to update my drivers. didn’t realize this was such a problem when I got this laptop.