DWG to USD conversion, materials not applied

Hello, I’ve posted several times recently about a similar issue, but I haven’t found a solution yet, so I’m posting again. Within Omniverse, applying materials to objects created works fine. However, when converting DWG data to USD, even when materials are applied, they only output as a solid color as shown in the pictures below (the same symptom occurs for all other materials). Also, there’s a log being printed as shown below, so I’m including that just in case.

Does anyone know how to solve this?

2023-08-12 02:08:09 [Error] [omni.hydra] Failed to create MDL shade node for prim ‘/Environment/Looks/Grid/Shader’. createMdlModule failed.
2023-08-12 02:08:09 [Warning] [rtx.neuraylib.plugin] Loading transaction committed (different thread). MdlModule is NOT in the DB (rtx_scope): ::Z73file_3A::Z16C_3A::Users::nuc::Desktop::Z8AOmniPBR_2Emdl
2023-08-12 02:08:09 [Error] [omni.hydra] Failed to create MDL shade node for prim ‘/World/Dogtown/Looks/Frame/Shader’. createMdlModule failed.
2023-08-12 02:08:09 [Error] [omni.hydra] Failed to create MDL shade node for prim ‘/World/Dogtown/Looks/Shelves/Shader’. createMdlModule failed.
2023-08-12 02:08:09 [Error] [omni.hydra] Failed to create MDL shade node for prim ‘/Environment/Looks/Grid/Shader’. createMdlModule failed.

["Before applying materials to the surface.]

["After applying materials to the surface.]

In Omniverse, I can apply materials as desired to the cube object created, but objects converted from CAD’s dwg file to usd are displayed in a single color only

This symptom also appears identically in objects of simple shapes.

Thanks for posting the question. I see it says here “when converting DWG data to USD”. How you do this is very important. If you are not using our official omniverse connector it may not work, and we do not actually have an AutoCAD connector. So that may be the problem. Let’s talk about your workflow. You are converting from dwg. From what software ? Autocad ? Are you importing the dwg directly into Composer, or exporting USD from AutoCAD ?

The single colors you are getting… are they roughly the color of the material you are applying ? Sometimes this happens in your UV scale is way way too small and the material is really in there but tiny.

Give me more details about your workflow and ideally show me a video of you importing the cad and trying to apply materials.

Could you also provide your dwg and usd scene please.

@inyong2327 presumably you were applying materials directly in AutoCAD with the ADSK Library. I would have to make an educated guess based on the console logs, it’s incompatible with MDL that OV uses during the conversion. this isn’t too dissimilar to the default physical material used in 3DS Max currently not being fully supported.

@Richard3D does bring a good point about your workflow, though, because applying materials in DCCs tend to rely on the OV connectors to translate shader properties. and without a proper connector for CAD in the first place, it may be something to evaluate. but i’ll let him provide you the guidance you need.

thanks for your response
I am solely using AutoCAD and I convert the DWG files to USD via using import from USD Composer.

Regarding the application of materials, whether I bring in a file with materials applied in AutoCAD or apply materials within USD Composer, in both instances, they appear as a single color.

Thank you for your response.
Indeed, for objects in CAD where no material settings have been applied, these logs don’t seem to appear. However, even after the import process, when I select materials using the Omniverse’s features, the same issue occurs. I’ve tested with other DWG files as well, and the same issue persists. If this is an issue arising due to the lack of a detailed Connector function , is there any reference material or link you could provide for guidance?

Additionally, if needed, I can send the DWG files used in the process, the converted USD, and the video in a message.

yup, i would definitely encourage providing those items you mentioned for more thorough inspection. if the contents have license sensitivity or you don’t feel comfortable sharing publicly, feel free to send it directly to @Richard3D via private messages.

I had already sent him the video and files. thanks

1 Like