Error in mlnxofedinstall in CentOS 7.8 Linux OS

I am having a centos 7.8 version, when I am installing ./mlnxofedinstall --add-kernel-support --skip-repo of MLNX_OFED_LINUX-5.1-2.3.7.1-rhel7.8-x86_64.iso. It is giving following error.

Attempting to perform Firmware update…

The firmware for this device is not distributed inside Mellanox driver: 65:00.0 (PSID: SM_2001000001033)

To obtain firmware for this device, please contact your HW vendor.

Failed to update Firmware.

See /tmp/MLNX_OFED_LINUX.43765.logs/fw_update.log

Hello Mahendra,

Thank you for posting your inquiry on the NVIDIA Networking Community.

We are reviewing the information you have provided and will get back to you as soon as possible.

Based on the information provided, you are using a Mellanox OEM adapter from SuperMicro → https://www.supermicro.com/en/products/accessories/addon/AOC-S100G-m2C.php

Even though you can we provide the MLNX_OFED driver through our website and you can install it on your system, the f/w for this adapter can only be provided by SuperMicro.

We recommend to reach out to SuperMicro so they can provide you with the latest f/w version available for this PSID

Thank you and regards,

~NVIDIA Networking Technical Support