Error while installing Eclipse Marketplace to Nsight

Hi,

I am trying to work with Drive AGX Xavier in the future.

Following this tutorial

https://developer.nvidia.com/drive/learn/tutorial-NsightEclipse

I am trying to install Eclipse marketplace as new software to Nsight on my host machine.

During the installation I get the error message:

An error occurred while installing the items
session context was:(profile=cider, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.equinox.launcher.gtk.linux.x86_64 1.1.200.v20140603-1326, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.equinox.launcher.gtk.linux.x86_64,1.1.200.v20140603-1326 was not found.

I can not find the file on my disk. Where can I find it or how can I solve the issue?
Thank you

Dear david.freund,

I’ve installed Eclipse marketplace you mentioned above without any problem.


Could you please let me know where the error occurred? Thanks.

Hi,

the error occurs when I try to install Eclipse marketplace. When I click on Help -> Install New Software.

In “Work with” I choose: Eclipse Juno repository - http://download.eclipse.org/releases/juno/

Then I choose the marketplace client from General Purpose Tools.

After that I click “Next” and "Finish in the next window. After that I accept two certificates, the installation continues before it finishes I get the Error message:

‘Installing Software’ has encountered a problem. An error occured while installing the items

An error occurred while installing the items
session context was:(profile=cider, phase=org.eclipse.equinox.internal.p2.engine.phases.Install, operand=null --> [R]org.eclipse.equinox.launcher.gtk.linux.x86_64 1.1.200.v20140603-1326, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).
The artifact file for osgi.bundle,org.eclipse.equinox.launcher.gtk.linux.x86_64,1.1.200.v20140603-1326 was not found.

Thank you for your help

Dear david.freund,

I checked the installation way on my two HostPC(Ubuntu 16.04 and 18.04) but there was no problem with the installation.

I’m not sure, could you please check if it is related to your company’s internal security or network issue?

Hello,

thank you for your help.

I kind of found the issue now. When I start Nsight from the command line by typing “nsight”, I am not able to install Eclipse Marketplace. When I start it from the search, I can install it without a problem.

I don’t know why that’s the case but it is working now.

I am facing the same issue. The problem appears for me with with fresh installs of of Kubuntu 20.04 as well as 18.04 running in VirtualBox. Both/usr/bin/nsight and /usr/lib/nvidia-nsight/nsight are affected.

Installed packages are
openjdk-8-jre (8u265-b01-0ubuntu2~18.04)
nvidia-nsight (9.1.85-3ubuntu1)
For the cuda installation I followed the instructions given in https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1804&target_type=debnetwork

I activated java8 via update-alternatives. Help would be much appreciated!





HI @Constantin,
can you please post your question on this category page:
https://forums.developer.nvidia.com/c/development-tools/cuda-developer-tools/285

thanks

1 Like