Error while running camera samples

Please provide the following info (tick the boxes after creating this topic):
Software Version
[*] DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)
DRIVE OS 6.0.4 SDK
other

Target Operating System
[*] Linux
QNX
other

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
[*] other

SDK Manager Version
1.9.2.10884
[*] other
1.9.3.10904

Host Machine Version
[*] native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers
other

I am trying to run some camera samples following this link https://developer.nvidia.com/docs/drive/drive-os/6.0.6/public/driveworks-nvsdk/dwx_camera_sample.html but I am getting these error.

nvidia@tegra-ubuntu:/usr/local/driveworks/samples/bin$ ./sample_camera
ProgramArguments: Missing argument 'dwTracePath' requested
GLFW error: 65544, X11: RandR gamma ramp support seems broken
libEGL warning: DRI2: failed to authenticate
terminate called after throwing an instance of 'std::bad_array_new_length'
  what():  std::bad_array_new_length
Aborted (core dumped)

Please provide the complete reproducing steps after flashing DRIVE OS.

I followed some of these steps to set up and access board through SSH.https://developer.nvidia.com/docs/drive/drive-os/latest/linux/sdk/common/topics/board/Setup_and_Configurations.html
After this I run some samples in host and target system following this link samples.
I am accessing GUI through VNC following this VNC

Dear @sankal.pattanashetti,
Are you accessing VNC via headless or non-headless mode? Could you share the steps?
Do you see blank screen when connected to target on VNC terminal?

I am accessing VNC via headless.I followed headless and Desktop FS section in this link.
I am getting full GUI.

After few days of working with VNC terminal, it got automatically disconnected. Now I am getting blank purple screen.How to solve this issue.

It seems that you were able to run the DW camera sample application through VNC, but the current issue is that VNC disconnected after a few days. If my understanding is correct, I suggest creating a separate topic specifically for the VNC issue. This will help ensure that the two issues are discussed separately and more effectively.

Now it’s working as previous session was present in temp so deleted it.

It appears that the issue has been resolved by deleting the previous session stored in the temporary files. If everything is working fine now, then it indicates that the problem has been successfully addressed. Please confirm if there are any further concerns or if there’s anything else I can assist you with.

Dear @VickNV thanks for the reply.The display error got solved.Camera samples were my primary problem.How can I test camera samples provided in /usr/local/driveworks/bin or through nvmedia samples.Is this can be done through terminal ?

You can run the camera apps through the terminal if a monitor is physically connected to the system or if rendering is disabled.

I am not able to get display physically connected to monitor. I am using GUI through X11.

Can you please clarify why having a physical display connected is not possible? Additionally, could you provide detailed steps for the headless mode setup? It would be helpful if you could also provide the xrandr output. Thank you.

Thanks for the reply @VickNV. I tried to connect different display and with different cables but it is not working. VNC I followed this link to get virtual display .

This is the output of xrandr

nvidia@tegra-ubuntu:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1920 x 1080, maximum 1920 x 1080
default connected primary 1920x1080+0+0 0mm x 0mm
1920x1080 60.00*
1680x1050 70.00 60.00
1400x1050 70.00 60.00
1600x900 60.00
1280x1024 75.00 60.00
1440x900 60.00
1400x900 60.00
1280x960 60.00
1368x768 60.00
1360x768 60.00
1280x800 60.00
1152x864 75.00 70.00 60.00
1280x720 60.00
1024x768 75.00 70.00 60.00
1024x576 60.00
960x600 60.00
832x624 75.00
960x540 60.00
800x600 75.00 72.00 60.00 56.00
840x525 70.00 60.00
864x486 60.00
700x525 70.00 60.00
800x450 60.00
640x512 75.00 60.00
720x450 60.00
700x450 60.00
640x480 75.00 73.00 60.00
684x384 60.00
680x384 60.00
640x400 60.00
576x432 75.00 70.00 60.00
640x360 60.00
512x384 75.00 70.00 60.00
512x288 60.00
416x312 75.00
480x270 60.00
400x300 75.00 72.00 60.00 56.00
432x243 60.00
320x240 75.00 73.00 60.00

Are you still using P3663 as in Download drive OS 6.0.0?

Yes, it is P3663.

Dear @sankal.pattanashetti,
Note that this forum is intended to support issues related to P3710. For issues with P3663, please contact your NVIDIA representative for correct support channel.

Besides that, I could run DW camera sample in headless mode with below steps on P3710

On terminal 1

sudo service gdm3 stop
sudo service gdm stop
sudo -b X -ac -noreset
export DISPLAY=:0
sudo xrandr --fb 1920x1080 #may fail
sudo x11vnc -geometry 1920x1080 -display :0 &

Connect to target using VNC Viewer, you would see a blank screen

Now launch the DW camera sample on terminal 2

nvidia@tegra-ubuntu:/usr/local/driveworks/bin$ ./sample_camera

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.