Display is not working after flashing

Please provide the following info (tick the boxes after creating this topic):
Software Version
[*] DRIVE OS 6.0.6
DRIVE OS 6.0.5
DRIVE OS 6.0.4 (rev. 1)

Target Operating System
[*] Linux

Hardware Platform
DRIVE AGX Orin Developer Kit (940-63710-0010-300)
DRIVE AGX Orin Developer Kit (940-63710-0010-200)
DRIVE AGX Orin Developer Kit (940-63710-0010-100)
DRIVE AGX Orin Developer Kit (940-63710-0010-D00)
DRIVE AGX Orin Developer Kit (940-63710-0010-C00)
DRIVE AGX Orin Developer Kit (not sure its number)
[*] other

SDK Manager Version
[*] other

Host Machine Version
[*] native Ubuntu Linux 20.04 Host installed with SDK Manager
native Ubuntu Linux 20.04 Host installed with DRIVE OS Docker Containers
native Ubuntu Linux 18.04 Host installed with DRIVE OS Docker Containers

I flashed orin board and wanted to check camera samples,but display is not working.How to get display in orin board?

Please search the forum for solutions for other developers’ topics. Here are some examples of forum threads that discuss similar issues:

I tried
1.Changing montitor
2.Changing cables
3.Uninstalling and installing gdm3
And other methods shown in the links.
But I am unable to get display.Even c ports and USB ports are not detecting.

Dear @sankal.pattanashetti,

wanted to check camera samples

How about acceesing target via VNC and check camera samples?

Thanks @SivaRamaKrishnaNV @VickNV through VNC I am able to get display.

What did you mean ‘Even c ports and USB ports are not detecting’? Please elaborate it.

From host system when I connect to debug and C port, only debug port(USB B type) is detecting. When I connect mouse to USB A port sometimes mouse light will be on and sometimes off.

jramesh@c623drd61102573:~$ lsusb
Bus 002 Device 003: ID 0bda:0328 Realtek Semiconductor Corp. USB3.0-CRW
Bus 002 Device 002: ID 0bda:0411 Realtek Semiconductor Corp. 4-Port USB 3.0 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 017: ID 0955:7045 NVIDIA Corp. 
Bus 001 Device 002: ID 0bda:5411 Realtek Semiconductor Corp. 4-Port USB 2.0 Hub
Bus 001 Device 015: ID 413c:2113 Dell Computer Corp. Dell KB216 Wired Keyboard
Bus 001 Device 016: ID 413c:301a Dell Computer Corp. Dell MS116 USB Optical Mouse
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This should be normal. Only after putting the system into recovery mode, you can see:

Bus 001 Device 014: ID 0955:7023 NVIDIA Corp. APX

Haven’t tried this.

Which camera sample did you try? Have you tried nvsipl_camera? Which camera module are you using? Is it listed in the following ecosystem pages as supported on 6.0.6?

  1. I am trying with this Samples .
  2. To work with nvsipl_camera what should be platform specified for.
  3. I am using camera given with drive agx xavier devkit that is SEKONIX SF3325-100.

Please refer to To run the sample applications and try nvsipl_camera with -d option on DRIVE OS.

Is this sample To run sample application works without display? as document is suggesting to stop display managers and other VNC method. As camera samples primarily asks for display as they pop-up as new tab.

How to find which platform should be specified for nvsipl_camera sample.

The application isn’t using x11 to render so it needs these steps to use the ‘-d’ option.

It depends on which camera module listed in the ecosystem pages is used.

Sekonix SF3325 which was given with Drive agx xavier devkit is listed in ecosystem page but it is not available in platform list.

Please can you elaborate.I am using X11 VNC to get display.Through this can I able to test camera samples.

Our design is such that only one graphics process, or graphics app, can run at a time. This means that running two graphics apps simultaneously is not supported. In the case of running the camera application with the ‘-d’ option, it does not use X11, so if you want to test camera samples, you would need to stop the existing process before running the camera application. This will ensure that only one graphics app is active at any given time.

Dear @VickNV thanks for the reply. If only one graphical process can be ran than how to test camera samples as I am using VNC to get display .Other than VNC display I tried all the methods to get display but none of them working.My end goal is to test camera samples.How to test them without diplay.Can we try with terminal if so please suggest me with document or command.

I believe my previous post should explain the display issue. Let’s discuss the camera issue with Error while running camera samples.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.