Failed to start Code2022.3.3

I’ve installed Code 2022.3.3 version successfully. But when I click Launch button ,there is no any application called.
I’ve tried go to the application folder , such as “C:\Users\myUsername\AppData\Local\ov\pkg\code-2022.3.3” and run omni.code.bat manually ,but display error message like “system can not find the specific path”.
What’ wrong ?
BTW , the OVE system is not good as we expected.

@Fuqifacai just a few things that came to my mind without seeing the Launcher log:

  1. do you have OneDrive and could be using it inadvertently? it has a tendency to redirect some install paths and lead to installation/launch errors from personal experience.
  2. does your username have any special character or spaces?
  3. are you having issues with only Code or with other OV apps as well?

regarding your comment about OV not being as good as you thought, i would just speak from my own experience that it does have a few extra things that it’s specific about. if you don’t go out of the way to customize the install or have unqiue setup, it shouldnt have any problem most of the time. and some quirks just come down to spending time with the program to get used to it much like any software.

Thanks reply , Guy.
1:I don’t have OneDrive installed.
2:my username is just like “chris.wade” , I think it should be ok . right ?
3:Only code can’t run. Composer, Nucleus, USD Viewer , Presenter ,all work fine .
Any idea or log I need to upload ?

I found there is a "kit’ link or virtual folder under Code’s main folder,
When I click to see its content , display same error message like when I run it .
Is that the problem ? Anyone else can see the ‘kit’ folder content?
Is Code rely on some kit version ?

the username format mentioned shouldn’t be a factor, in that case (as long as it’s of ascii and not unique characters). and personally i havent had issues with the kit folder access, so i’ll defer to the mod on that. my understanding is there will be different kit versions for different version of the app. for example, 2022 apps seem to be built on kit 104, and 2023 apps are built on kit105. i am sure it has a lot more relevance than just versions of the app, but it’s one way to look at it. speaking of, have you tried an older Code version?

the log i was referring to is the Launcher log, since you have experienced the same problem when launching the app both ways; you can find the location of the launcher log here:


1 Like

Let’s start over by just uninstalling Code and reinstalling the LATEST VERSION. Then lets go from there. If it fails to start then lets get a video of that and your launcher logs. C:\Users%username%.nvidia-omniverse\logs\launcher.log

1 Like

I tried this way before maybe 3 times , all failed.
I am lucky , today I try this way and it works fine.
Thanks anyway .
But still want to complain a little bit . OVE is still not good enough.

Yes, the kit version is the key and answer.
I just make sure 2023.1.1 use kit 105 , it works fine.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.