Flash Pegasus with DRIVE OS 5.1.6.0, no reboot

Hi,

After successfully flash pegasus Xavier A with DRIVE OS 5.1.6.0, there is no reboot. I cannot start the system anymore.

I have flashed the system with DRIVE OS 5.1.0.2 and it reboot automatically. No problem at all.

The OS of pegasus is Ubuntu 16.04. Is that becacuse 5.1.6.0 only support 18.04? What is the right way to do it? Should I upgrade my pegasus os to Ubuntu 18.04? Is there anything I am missing?

Thanks!
sdkm1.log (5 MB)
sdkm.log (4.8 MB)
logs.tar.gz (838 KB)

Dear JX,

Could you please upload the full logs available at below locations for your topic?
~/.nvsdkm/sdkm.log
~/.nvsdkm/logs

And can you access to the Drive AGX Pegasus via minicom?
If yes, please also attach the log also. Thanks.

I have tried for two times, so there are two log files.

Hi JX,

From the log, I see that all .run files were installed without error and flashing went smoothly.

After the board is flashed with 5.1.6.0, did you connect it with HDMI output or only with minicom? The expected result is run-once script will automatically run to install softwares on first boot. At this time, if you connect the board to minicom, there is no response. It will only has response after the run-once script is completed. This process may take a while.

Can you please check if this is the case for you?
If not, can you please provide the minicom output of Tegra A after flashing?

Hi,

Yes, I connect it with HDMI. There is no video output. The first time boot did not happen.

I have the same setup and when I flash with 5.1.0.2, there is no problem. It can reboot and load the software by itself with no problem at all. Is there any difference in the process between this two versions? I use the sdkmanager on a host machine.

I am very busy recently, some of my colleague will take over and work on it from next week. He will help to provide all the information you want.

Thank you!

Hi Edward,

Thank you for your reply. I am taking over from JX regard to this issue.

At the trail with 5.1.6.0, we have tried both with and without Minicom plugged and unplugged. However both scenarios were not helped, the monitor was remaining in Black without any display approx 5 minutes.

Which this leads to my next question, Would you please tell me how long do we suppose to wait after the software has been successfully uploaded to Pegasus?

And FYI,
When we installed 5.1.0.2. As soon as NVIDIA SDK Manager shown “Complete” sign, Pegasus will show a window immediately with a progress bar for the installation. However, we did not see this window on 5.1.6.0.

Hope this will help your escalation.

Thanks!

Thanks JX, XY1,

[Edit]
Actually 5.1.6.0 is different from all previous releases in that it does not have a desktop in the target RFS, so it is expected that nothing shows up on the Display. Console (minicom) has no response after the first boot for about 20 - 30 minutes when installing softwares.
But there should still be console spew as soon as the board powers up. If console prompt never comes or there is some other issue, would you please attach the Xavier AND the Aurix console outputs during boot?

Hi Edwards,

We have tired several method, however it was still not working.

  1. We setup minicom through ttyUSB1, however connection has been established, but no response.
  2. We have tired re-install the Drive OS 9.0, however we are getting “TensorRT Compile For Linux” module failed.

And, since we have tired but not getting a result, may I ask for a tutorial of how to get the Xavier AND the Aurix console outputs during boot?

Thank you very much and I look forward to hearing from you!

Best,

SDKM_logs_DRIVE_Software_9.0_Linux_for_DRIVE_AGX_Developer_Kit_06242019_1630.zip (1.3 MB)

Dear XY1,

ttyUSB1 is not for DriveAGX. Please see below.

https://docs.nvidia.com/drive/active/5.1.0.2L/nvvib_docs/index.html#page/DRIVE_OS_Linux_SDK_Development_Guide%2FFlashing%20Customization%2Fflash_xavier.html
• AURIX UART: /dev/ttyUSB3
• Tegra A UART: /dev/ttyUSB2
• Tegra B UART: /dev/ttyUSB6

And could you please save the log using below command on your hostPC and upload it? Thanks.
Tegra A : $sudo minicom -D /dev/ttyUSB2 -C TegraA.txt
Tegra B : $sudo minicom -D /dev/ttyUSB6 -C TegraB.txt

Hi Steve,

Thanks for replying, I’d like to conclude our try yesterday.

  1. We have connect the USB-A to USB-A cable into Debug USB at back panel of the AGX Pegasus during flash, this step was required by SDK Manager. There was no other USB devices connected during this step, with Console (Minicom) shown only ttyUSB1 connected. It was no response and no output at all during flashing and booting.
  2. The HDMI was no output before, on and after the flash. We were waited approx 45 minutes after flashing. However still no response.

As your recommendation, since I have to use Debug USB to flash the 5.1.6.0. Shall I connect another USB cable from Tegra A to my host PC, while the Debug USB remaining plug?

Please advice and thank you for your time.

And, I have tried to reinstall 5.1.6.0, the installation was went through.

Minicom was able to capture from Tegra A during the installation. However, minicom was not able to capture anything after the installation finished until this moment (approx 2 hours). And HDMI port remaining no output.

I have attached the log in this post. Please advice.

Tegra A.txt (8.58 KB)

Dear XY1,

Thank you for your update.
Could you please upload Aurix log with below command? Thanks.
Aurix : $sudo minicom -D /dev/ttyUSB3 -C Aurix.txt

Hi Steve & Edward,

Thanks for your update.
I’d like to make sure one thing. By “first boot”, does it mean, after flashing, Pegasus would automatically reboot itself? Or we need to manually reboot it?

Thanks,

Yes. Pegasus will automatically reboot after flashing.

Hi Edward,

According to our try yesterday. The Pegasus was not rebooted at all after installation.

I tried manually reboot this morning, Minicom was able to get some message. However, it went to multiple errors quickly.

At this moment, the HDMI still remain in no output, and we still unable to control the Tegra A or B by any chance.

I have attached the logs below.

Thank you again and please advice.

TegraA 20190627.txt (524 Bytes)

TegraB 20190627.txt (828 Bytes)

Aurix 20190627.txt (96.3 KB)

Hi Edward & Steve,

XY and I were testing this yesterday.

We were actually not sure if Pegasus has rebooted or not, it just had nothing show up on three minicom terminals for several hours after successfully installing it.

Then we did a manual reboot this morning.

Dear haoran.wang0gqpx,

May I know if the issue still happens or not?
If still happens, can we access/log in your system to see? Thanks.

Hi Steve,

I could log in the flashed Pegasus now. I did two things 1) reboot the host 2) disable hardware control flow in minicom.

Then type 'minicom -D /dev/ttyUSB2", a black green comes up. Then one needs to type several random keys to see the login terminal.

Thanks for your help