Flashing lights

I am playing with the extraordinary good tool HDR Light Studio.

I found out that Omniverse dome lights can cause some nasty fire flies: Noise issue and OptiX denoiser - #6 by pekka.varis

So I deactivated them totally and used only the area lights created by HDR Studio Light:

Settings are 200 samples + 8 subframes on motion blur. This should be enough for noiseless free render. But now we get that flashing light issue, see on the asphalt at down left corner.

The error is the same with OV native large sphere lights:

Again, the issue is not from HDR Light Studio.
Nvidia, please help us.

Same results, flickering asphalt:

512 Samples, 5 subframes with motion blur, only one area light from HDR Studio Light.

I made a OV native lights setup here:

Same flickering!
I have to now check if is the bridge asset :P

Thank god it is not the bridge asset ( UE marketplace ).
Path Traced render with native distant light:

Then I made a simple 7 native rectangle light “rim” setup:

And as strange as it is, also this have the flickering problem, rendered with Path Traced 64 samples + 5 motion blur subframes. See?

Then I made a 3 native rectangle light rim setup, like this:

And we have no flickering at all, same rendering settings:

So please help me to figure out what is this flickering problem?
I can send you the scenes…

No flickering with native 3 light RIM & CC character. 80 samples / 5 motion blur subframes:

I can continue by bringing in HDR Light Studio Areal Light.

Both the flickers and the fireflies should be addressed in the internal builds already.

We are trying to repro the result that you showed with that scene to confirm.
In the meantime, can you share your scenes so we can verify that it works with them as well?

You can mail to btaskov@nvidia.com.

Thanks for the reports,

1 Like

Cool! Both scenes sent to you Blago,

If the “fix” for the flickering involves settings on the area lights that HDR Light Studio created then do let me know and I can address that in the Light Studio connection.

  • Simon.

@simon11 I am installing the latest HDR Light Studio tomorrow to test it, straight with a commercial project.

About this flickering, they wrote me from HDR Light Studio :

“A workaround for now is to convert the EXR map to a HDR map for the Domelight, which will result in less fireflies and will also render much faster to a noise free image.”

That worked. I test both EXR and HDR with the latest one.
I keep you informed.


is this a general thing with dome lights in omniverse? one should convert EXR to HDR?

No, it is only here with HRD Light Studio connector. And maybe it´s fixed in this latest update…