Noise issue and OptiX denoiser

I made this with CC & HDR Light Studio:

It is not ready, as you can see…

My settings were 512 samples in Path Tracing, no motion blur and:

I tried to solve the firefly issue with OptiX denoiser:

It works, but I feel that Optix denoiser takes also away some crispiness from the render.

Do I have any settings to change to find a better balance when fighting the fireflies? I know they are coming from the reflective floor surface, since in the first cc & HDR Light Studio render I did not had this problem: Beutiful skin with CC character & HDR Light Studio

I tried to fix it with these settings:

But I just ended up blowing the render time to 1+ hour…

Hey, I found the reason for the extra fireflies!

It was all coming from the stupidly large golden floor plane.
I deleted it and I get totally perfect noise free renders with default rendering settings.

Here I have a much smaller plane as ground:

Fullrez: https://catchline.fi/toveri/26-11-Hunt6.0000.png

5333 x 3000 pix 512 samples, rendering time 3 minutes with my RTX 2070 super.

What next to fight the fire flies, OptiX denoiser activation maybe?

Update to this study. I made same kind of lighs with native Omniverse lights.

No noise or Fire flies on this large rendering:

Fullrez 7111 x 4000 pix

Another quick variant with native lights & path traced fog:

Then I tried again with HRD Studio Lights, first without Environment Dome light to keep things simple, 512 samples:

As you can see, the light quality is better , but also we get much more of overall noise with this. Before I start to play with Optix desoiser, what are my options here to tweak the settings and have a less noisy image ?

Here is the same scene with 1500 samples:


Fullrez 3555 x 2000 https://catchline.fi/toveri/1500Samples.0000.png

Lets make it better, 2500 samples:

Fullrez 5333 x 3000

Rendering times are like 17 minutes… Much longer than with native lights. It might be that this tool is usefull only for still image renders :/

And finally with also the environment dome light, so full HDR Light Studio scene in use:

Fullrez 5333 x 3000

Now if you zoom on the fullrez, you can see the extra fire flies coming!
So HDR Light Studio´s environment dome + reflecting plane under the character together make this. Strange?

It´s not even the plane! It´s the environment dome light, see

Fullrez 5333 x 3000: https://catchline.fi/toveri/no-plane_HDR_SL_also-dome-2500.0000.png

Render time 7 min.

Yes, this proves it, it is the the environment dome light that makes those fire flies. Here we have the render without that dome, all clean:

FullRez 5333 x 3000:

One thing I next try is rendering a larger image for that environment dome… But all help is welcome with this :)

I think someone from NVIDIA needs to give some advice on this. Your findings do not apply to only HDRI maps made with HDR Light Studio, but this would be with any dome lighting. So its a general issue, not specific to HDR Light Studio.

BTW, all lights in HDR Light Studio can be selected and converted to Omniverse Area Lights by pressing CTRL + Space bar. So you get the best of both words using that method.

Mark you are right, hopefully Nvidia’s rendering & lighting gurus find some time to help us…

Here we have a render with NO HRD Studio Dome light:

Rullrez 7111 x 4000:

samples 2500
Rendertime 33 min.
In HDR Studio I used now these higher settings:

Map settings
Resolution 10000 x 5000

Area Lights settings
res: 2500

Options
EXR Options 32 bit floating

It is totally noise free, and no Optix denoiser in use.

Then again here is the same scene with only the DOME light. Same settings in rendering:

Rullrez 7111 x 4000:


Rendering time 14 min.

So here we can see that it is the HDR Studio Light domelight that bring in the extra fire flies. Nvidia, please can you help us here?

I think you should not confuse the situation by saying the ‘HDR Light Studio dome light’ is creating the issue.

The issue is generated by just the Omniverse dome light… we just make a HDRI map that is used by it. You would get the issue with any HDRI map produced by any method… I am guessing the map you have created has small and very bright lights on it… which is a more difficult situation for the renderer to handle. But most renderers have ways to deal with this and use importance sampling methods from the HDRI map, to reduce noise from small bright lights by sampling the bright areas more, and producing smoother renders. Let’s see if anyone technical from NVIDIA has anything to say.

You are correct. Sorry Mark!
I am still testing the OV dome light, your Analytics sound good to me.

I just bumped to a new problem when rendering animation. I am writing the post right now…

Your settings are crazy high on the sample count, I would do a 1440p image with Optix and work with the power of the lights being lower but the exposure being higher.

Chris, thaNK you! You have such a deep knowledge…
220 samples, 5 motionblur subframes.

I dropped the rendering time to 2min 15 sec (RTX 2070 Super)

However, the noise issue with dome light is visible. Good news is they are working on it :)

(post deleted by author)

(post deleted by author)

Lets take back one step
120samples
5 motion blurs
Optix 0.16

I raised iso to 800 ( btw my Red One MX camera default )
And I dropped the intensity of all lights.
Cool! It looks better and renders 4 min 50 sec.

Basically same settings, but now with new CC SkinGen skin & redhead. Looks much more healthy :P

120samples
5 motion blurs
Optix 0.4
F-stop 2.6
Rendertime 6 min

Rendertime is longer since the new Skingen texture is 4K! Gotta make a new smaller export since now I aim to 1440p renders…

2K Skin map
110samples
4 motion blurs
Optix 0.4
Render time 4 min 50 sec.

Notice how we start to loose the skin details, since too little samples and too much OptiX…

1440P
200 samples
5 motion blurs
Optix 0.4
Render time 11 min.
Perfect.

Overkill of settings :P

1440P
200 samples
10 motion blurs
Optix 0.7
Render time 22 min.

Difference to the one above is almost unseen, but 200 % slower to render.

5333 x 3000
250 samples
10 motion blurs
Optix 0.7
Render time 1h 30min