Disable sampled direct lighting for dome light

when in real-time render context

enabling :‘enable sampled direct lighting’ when using a dome hdri light I get extreme flickering noise in my SSS material.

It would be great to have an option specific to dome lights to disable sampling.

disabling this global settings removes the flickering artifact but also makes areas lights less nice looking. ( fall off / shaping doesnt get computed in the SSS. )

This only effects SSS materials.

Hello @JC_sculpture! We do have an option to not sample the Dome Light.

Will this help with what you need?

2 Likes

thank you, however disabling this causes the HDRI not to cast ambient lighting, which is a nice way to create a global illumination effect.
it would be nice in that same drop down you showed to have an option for ‘disable sampled direct lighting’ which makes the fireflies go away for domelights, but still retaining the nicer looking area lights.

1 Like