Flashing problem


I’m having trouble flashing P2379 using the recent DriveInstall_5.0.5.0aL_SDK_b19.run.

Aurix version is DRIVE-V5.0.5-P2379-EB-Aurix-With3LSS-4.02.02

First of all, although I have root privileges on the host machine, the installer won’t accept my password and the only option that worked for me was the silent installation:

launcher_silent_mode=install development_platform=autochauffeur ./DriveInstall_5.0.5.0aL_SDK_b19.run

It proceeded with the full install, including flashing both Tegras. Since that’s what I wanted to do anyway, I didn’t care much about this issue. The process finished normally and I’ve noticed nothing suspicious in the log ([url]https://drive.google.com/open?id=1tyXif9MfSIoX7UwYPqhEXPiQCpaiiV5I[/url]).

The monitor attached to the Tegra A HDMI shows the ‘Auto-Run of Drive-Setup Scripts’ stuck at the red line ‘First-boot script processing complete’.

The debug console shows that a bunch of network-related services failed to start ([url]https://drive.google.com/open?id=1BIZIyk3Dn67Sm9-uhtIJcuSBh0XXkL70[/url]). Consequently, Tegras aren’t accessible over ssh.

Your help would be very appreciated.

Dear aleksandr.gorlin,

Could you please help to check Aurix FW version via minicom application?

If Aurix FW version is not 4.02.02, could you please update Aurix FW with below guidance? Thanks.

As I mentioned, Aurix version is 4.02.02. Since it’s the version supplied with the most recent DriveInstall, I don’t quite understand how it’s possible to update it any further.

Dear aleksandr.gorlin,

Sometimes the firmware of Aurix isn’t automatically updated.
So I taught you how to do it by manual.
Based on some customers experience, companys network security issues have frequently caused this problem.
So could you please check your network security policy also? Thanks.

Dear Steve,

I’ve already flashed Aurix several times using Windows machine, this doesn’t change anything. I’m pretty sure the problem is somewhere else.

As an experiment, I’ve tried to run an older version of DriveInstall ( It worked a bit better,
at least auto-run scripts ran successfully and the GUI wizard finished. That made it possible to access Tegra A through the debug interface and I’ve noticed that all network interfaces are down. Typing sudo dhclient in minicom brings them up and Tegra becomes accessible over ssh. In other words, the hardware seems to be OK, it’s just the interfaces are misconfigured for some reason.

Unfortunately, I can’t do the same with DriveInstall, since the GUI wizard never exits, the ‘Next’ button is disabled, and I can’t interrupt it from the debug console either (Ctrl-C has no effect).

I should have probably mentioned it earlier: the problem is long solved. Apparently there’s something specific in the Ubuntu image used for workstation deployment in our company which prevents DriveInstall from running all the required scripts on Drive PX. Running the installer on a machine with default Ubuntu 16.04 resolves these issues.

So, does it mean we cannot install Drive-works partially on a Linux 14.04 docker machine?
After ‘launcher_silent_mode=install development_platform=autochauffeur ./DriveInstall_5.0.5.0bL_SDK_b3.run’, if you pause and select packages, it works. But I could not an option to do it without launcher_silent_mode=install.