No screen after flashing

Hi!

In December we got our DrivePX AutoChauffeur. We flashed the hardware after noticing that the installed DriveWorks version was old already. During the flash process everything went fine but if we boot up the system, the screen of both, Tegra A and B aren’t getting any signal. The network interface of Tegra A seems to be active but we cannot connect via SSH. We didn’t flash the AURIX because we have no RS232 interface atm. Is it necessary to flash AURIX? Should an SSH connection be possible? And what else can we try to get the system running or at least debug it?

Thanks in advance,
Bernhard

Dear DeepBernhard,

Yes, it needs to flash AURIX FW to match SW version. Thanks.

Thanks for your quick answer, unfortunate after flashing AURIX we still aren’t getting any screen signal after starting. While checking through the different COM ports for flashing I at least saw that there are Ubuntu login prompts on the different ports. Do you have any idea how to deal with that situation? Is there anything we can check or execute through console? Should we run the whole update process again?

Dear DeepBernhard,

May I know how to update DrivePX2 SDK and SDK/Aurix FW version you used?
I guess SDK is 5.0.5.0 and Aurix FW is 4.02.02. Could you please confirm it? Thanks.

Yes, I can confirm this, we took the newest downloads for the AutoChauffeur hardware

We really need support on this to get it running again.

Dear DeepBernhard,

Could please you check DrivePX2 Aurix FW version via minicom program?
It needs to make sure Aurix FW was flashed or not.
Please see the following Flashing Aurix manner. Thanks.
http://docs.nvidia.com/drive/nvvib_docs/index.html#page/NVIDIA%20DRIVE%20Linux%20SDK%20Development%20Guide%2FFlashing%2Fflash_aurix_dpx.html%23wwpID0E0WC0HA

We had the newest version of the AURIX installed already. After flashing again the DrivePX came up with Gnome again. But since Driveworks was missing, we uninstalled and reinstalled ‘Driveworks on target’ and flashed DrivePX again. Still no luck, DriveInstall tells us that Driveworks is already installed, but there isn’t even the folder /usr/local/driveworks in the filesystem. The desktop shows the typical links to start a Camera Test and Drive Net(live/file), but they don’t work. We now try to completely download, reinstall and flash everything through DriveInstall from scratch.

The original problem has been solved by flashing again through DriveInstall, but have you any experience on a missing Driveworks installation?

We are still downloading, but I wanted to add the errors of the log file in /var/log/ (Err:7 & Err:10 are reoccurring):

Err:7 file:/root/apt-repos binary-DWx/ Packages
File not found - /root/apt-repos/binary-DWx/Packages (2: No such file or directory)

Err:10 file:/root/apt-repos binary/ Packages
File not found - /root/apt-repos/binary/Packages (2: No such file or directory)

Err:3 file:/root/apt-repos binary/ Packages
File not found - /root/apt-repos/binary/Packages (2: No such file or directory)

Err:5 file:/root/apt-repos binary/ Packages
File not found - /root/apt-repos/binary/Packages (2: No such file or directory)

In the meanwhile we were able to resurrect our DrivePX 2 AutoChauffeur by downloading, installing, and flashing through DriveInstall again. There might was a problem with an interrupted download.

Thx 4 support