Tegra A reboot after flashing

I had updated a Drive PX2 Autochauffeuer to the last OS 5.0.10.3 and after the flashing the Tegra A cannot boot the linux and keep rebooting the Tegra B. I also tried to flash just the Tegra A and during the final instalations and setup in Tegra A after the flashing is possible to normally use Tegra B. Before I finishing the accept of terms, definition of the date… the Drive PX reboot and before it the monitor connected to the Tegra A keeps black and the Tegra B starts, and when finish to open the web browser all the Drive PX reboot.

I was using ethernet cable and the devide was working before the update.

I attached the sdkm.log
https://drive.google.com/open?id=1nC4GT_rDo64huqv1Iyt0vlirHxVnXNnq

Thank you in advance.

Dear Reway,
From the sdkm.log it is clear that Tegra A flashing is skipped.
Could you delete ~/.nvsdkm folder and remove the DRIVE 5.0.10.3 installation and attempt a fresh installation once again. Please check https://devtalk.nvidia.com/default/topic/1047490/faq/flashing-issues-on-drive-px2-amp-drive-agx-xavier/ for some known errors and work around. If it still fails, Please upload ~/.nvsdkm/logs and ~/.nvsdkm/sdkm.log in the thread.

Dear Siva,

I made the indicated but the problem persists.
I attached the desired files:
https://drive.google.com/open?id=1UbitdD9PK0MwjHSHkt6IzCqVWCUtWJRB
How should I proceed to solve this problem?

Thank you.

Dear Reway,
Could you share the following thing to get more insights.
What is your Host kernel version and Aurix version?
Is the board used on Desk or inside car?
Did you connect both Host and board to internet while flashing?
What happens when you flash the Tegras one after another?

Dear Siva,

Host Kernel is:
4.15.0-58-generic

Aurix Version:
SW Version: DRIVER-V5.0.5-P2379-EB-Aurix-With3LSS-4.02.02

Yes, both Host and board were connected to internet.

When I flash just TEGRA A the problem persists.

Dear Reway,
As per https://devtalk.nvidia.com/default/topic/1047490/faq/flashing-issues-on-drive-px2-amp-drive-agx-xavier/, customer are facing flashing issues If the kernel version is 4.15.0-45 or above. Could you downgrade your kernesl version and check flashing as mentioned in the link.

I also checked the linux boot terminal and I saw it:

tegra-ubuntu login: [   24.281098] tegradc 15200000.nvdisplay: can't set parent_clk_safe for sor->ref_clk

[   24.396265] tegradc 15220000.nvdisplay: can't set parent_clk_safe for sor->ref_clk

[   24.625149] tegradc 15200000.nvdisplay: can't set parent_clk_safe for sor->ref_clk

[   24.718547] tegradc 15220000.nvdisplay: can't set parent_clk_safe for sor->ref_clk

[   25.553981] tegradc 15200000.nvdisplay: can't set parent_clk_safe for sor->ref_clk

[   25.655665] tegradc 15220000.nvdisplay: can't set parent_clk_safe for sor->ref_clk

NOTICE:  BL31: v1.3(release):934cbe7

NOTICE:  BL31: Built : 10:49:21, Sep  4 2018

▒▒▒▒DRIVE Hypervisor

▒starting app debug_server

D-S> Starting TrustZone Sever...

Reserved IVC id 520

Reserved IVC id 521

Resplatform_guest_warm_boot: guest warm reboot

platform_guest_warm_boot: guest warm reboot

eplatform_guest_warm_boot: guest warm reboot

rplatform_guest_warm_boot: guest warm reboot

platform_guest_warm_boot: guest warm reboot

platform_guest_warm_boot: guest warm reboot

ved IVC id 522platform_guest_warm_boot: guest warm reboot

Dear Reway,
Could you please confirm if you have attempted flashing using downgraded kernel? If not, please check that first as it is a known issue.

Dear Siva,

I already downgraded the kernel to 4.13.0-41-generic, deleted ~/.nvsdkm folder, removed the DRIVE 5.0.10.3 installation and I did a fresh new installation again and the problem persist.

Dear Reway,
Please attach the latest logs here(~/.nvsdkm/logs and sdkm.log). We will check with internal team and get back to you.

I attached the last logs in google drive:

https://drive.google.com/open?id=1En__5h52Xwfta_ClRFOAJ5A4r5l84Df0

Dear Siva,

I tried to flash the board from another Host-PC and I had the same problem. Did you get in touch with the internal team?

Thank you.

Dear Reway,
I am yet to get response from the team. Do you see the same error from another host?

Dear Siva,

Yes, When flashed from the second Host, the board present the same “Rebooting” problem. In both Hosts the characteristic is the same:

After the sucessfull flashing presented in the Host both TEGRAS show a window with:

  • Introduction;
  • Time definition;
  • License agreement.

If I proceed with this setup just in TEGRA B, I can use TEGRA B normally. However, If I finish it in TEGRA A, it starts the rebooting of the complete board.

Dear Reway,
We suspect Aurix is not flashed correctly. Turn off your board and connect your host PC and board via usb-usb cable. Open minicom connection to Aurix and both Tegras. Once you turn on board, you can see booting outputs for these. Please share those logs.

Dear Siva,

I uploaded the desirable logs in the link below.

https://drive.google.com/open?id=18FiqWjJjai0WOUU3DFnySu5f5w0HvSQd

it consists of three boots. During the first one TEGRA A was in the first configuration window. After that I did the:

  • Introduction;
  • Time definition;
  • License agreement

and the board rebooted more two times.

Whether you have more questions or possible solutions do not hesitate to contact me.

Dear Reway,
Thanks for sharing the logs. I will get back to you

Dear Reway,
It seems Aurix is not updated correctly. Could you please reflash the aurix. Please check https://docs.nvidia.com/drive/active/5.0.10.3L/nvvib_docs/index.html#page/NVIDIA%2520DRIVE%2520Linux%2520SDK%2520Development%2520Guide%2FFlashing%2Fflash_aurix_dpx.html

Der Siva,

I refreshed the Aurix accordly to the link and the board is working now.

Thank you so much for the support.