AutoCruise Aurix flashing failed, not reachable anymore

Hi together,

We currently have a problem after flashing the current 5.0.5.0a Release to our AutoCruise PX2.

The Linux falshing worked fine, by running DriveInstall, but afterwards the Aurix flashing has failed. Now the Aurix is neither reachable nor flashable anymore.

We tried running the DriveInstall again and also connecting through the Debug USB by minicom.

When we start minicom before the PX2 boots, we are able to receive the following message, afterwards the Aurix seems to crash or at least is absolutely nonresponsive:

AutoCruise Aurix Serial Console
P3407-A01 Variant A
with TLF35584 B/C-Step
SW Version  2.01

Enter 'help' to see the available commands

Shell>TacpQspi: received command: PING

TacpQspi: response to Tegra: ACK

TacpQspi: received command: invalid

TacpQspi: response to Tegra: invalid

TacpQspi: received command: invalid

TacpQspi: response to Tegra: invalid

TacpQspi: received command: invalid

TacpQspi: response to Tegra: invalid

TacpQspi: received command: invalid

TacpQspi: response to Tegra:

The part until the Shell input is received close to instantly. But no user input like ‘version’ is processed if anything is provided. The follwing TacpQspi output takes about 5 seconds to appear.

As it can be seen the Aurix is not on the current FW and we’d like to update that.

Running an upgrade for the AutoChauffeur worked flawless.

Any help would be appreciated.

Dear bewert,
Can you confirm if you have followed the post installation steps provided at http://docs.nvidia.com/drive/driveinstall_docs/index.html#developertools/mobile/driveinstall/linux/5.0.5.0a/sdk/install.htm%3FTocPath%3D_____3

Hi SivaRamaKrishna,

Yes we tried running the post installation scripts, that’s when we first found out that we might have an issue with the Aurix.

Those were the outputs:
sudo /usr/bin/nv_aurix_update -get_fw_version

query_fw_version: Receive Timeout. Packet loss
Please rerun nv_aurix_update app or check Ethernet configuration
Query Version failed

Since we were unable to get the fw information, we ran the auto update anyway

sudo /bin/bash /etc/systemd/scripts/nv_aurix_check_fw.sh -auto_update

starting Aurix FW checking...
Checking arguments...
Rootfs EB FW version is 4.02.02.0
No_Response_From_Aurix
--------------------------------------------------------------------
!!! IMPORTANT INFORMATION BELOW REGARDING Aurix FW (PLEASE READ) !!!
 
No response from Aurix FW. It seems
SPI-TP not configured
Please check your nv_spi_tp systemd service
 
THIS MESSAGE WILL CONTINUE TO BE SHOWN UNTIL ACTION MENTIONED IS TAKEN
With action taken, this script will be muted and not shown again
----------------------------------------------------------------------

To ensure the nv_spi_tp is running we checked it’s status with
sudo service nv_spi_tp status
which showed us that the service is running fine.

Afterwards we unsuccessfully tried to connect to the Aurix via debug cable as mentioned in the initial post.

Dear bewert,

Could you please re-try to flash Aurix with below method? Thanks.

https://docs.nvidia.com/drive/nvvib_docs/index.html#page/NVIDIA%20DRIVE%20Linux%20SDK%20Development%20Guide%2FFlashing%2Fflash_aurix_dpx.html%23

Hi Steve,

sorry for the late reply, but I wasn’t available the last days.

The Link you provided was the procedure we tried after the DriveInstall didn’t work properly. This procedure does not work due to us not being able to connect to the Aurix. The symptoms are like another thread here that was solved by terminating an existing minicom connection.

This is not applicable to us (I think), since this also happens after a host reboot. Another thing is that by using the identical host to connect to another Aurix (on our AutoChauffeur) everything works fine.

any news on this?

The device is still unresponsive with the symptoms from the earlier posts.

Dear bewert,

Did you remove all the USB devices like USB keyboard/mouse before flash Aurix FW?
If not, please remove all USB devices and re-try to flash. Thanks.