[solved] DriveInstall - Failed to flash device

Hi,

I have just tried to flash our NVIDIA DRIVE PX 2 AUTOCHAUFFEUR (P2379) to version 5.0.5.0 through DriveInstall_5.0.5.0L_SDK_b96.run.

While the installation of all the packages on the development machine worked. The flashing failed at a certain point with the following error message:

/home/nvidia/NVIDIA/Drive/5050L_SDK///_installer/run_command -c=“chgrp -R nvidia /home/nvidia/NVIDIA/Drive/5050L_SDK//DriveSDK/drive-t186ref-foundation//utils/scripts/bootburn/_temp_dump/” -d=/home/nvidia/NVIDIA/Drive/5050L_SDK///_installer/tmp
1
Failed to flash device. Please check /home/nvidia/NVIDIA/Drive/5050L_SDK/_installer/logs/flash_dual_tegras.log for more details

I have uploaded all the relevant log files here:

https://drive.google.com/open?id=15T4vJ5eGeGZMvTHNCs9Ms_I2-SHbx4bm

When I now boot up the PX 2, I get no screen signal. One of the fans spins up loud for a few seconds, then stops and then repeats the same behaviour. I am able to flash the system again, but it fails at the same point.

I have repeated the flashing procedure 3 times. Restart the host and device between the tries. I always get the same error.

How can I proceed further?

Kind regards,
Christian

Dear christian.brugger,

Did you flash Aurix F/W?
If not, please update Aurix F/W also. Thanks. http://docs.nvidia.com/drive/nvvib_docs/index.html#page/NVIDIA%20DRIVE%20Linux%20SDK%20Development%20Guide%2FFlashing%2Fflash_aurix_dpx.html%23wwpID0E0WC0HA

It worked.

Before the update my Aurix firmware version was: DPX2-P2379-EB-Aurix-2.02.04.

I then used the tool Triload.bat and flashed the hex file: EB-DrivePX-Aurix/DRIVE-V5.0.5-P2379-EB-Aurix-With3LSS-4.02.02.hex

After that flashing both Tegras with the DriveInstall_5.0.5.0L_SDK_b96.run succeeded. And both device boot into Linux.

Thanks for your help Steve!

Kind regards,
Christian