DrivePX 2 DriveInstall crashes during flashing

Hi,

I downloaded all the files that is needed to setup Driveinstall from NVONLINE and followed the instruction on Driveinstall readm_me_first.pdf. I’m running Ubuntu 14.04.3 kernal 3.18.0. I have not installed any video driver for my GTX 960 TI. First, I run a custom install were I did not flash Tegras and it successfully installed. After restarting the host PC. I run Driveinstall again to flash both Tegras.

I followed the instruction of removing all USBs from both the host and Drive PX and connect both Host and platform to the Internet . During the Installation process It start showing timeout on the Terminal log screen. I paused and resumed and the same-thing happened to Tegra B

Press CTRL-A Z for help on special keys
Timeout

the Drive PX2 screen turned black (No Signal). I reset both DrivePX and host PC and started the flashing process again. this time I completed the installation process without any issues. However, I stall have a black screen (No Signal) on drive PX. I connected to Tegra A via minicom and it looks functional

nvidia@tegra-ubuntu:~$ uname -a
Linux tegra-ubuntu 4.4.15-rt25-tegra #1 SMP PREEMPT RT Sat Feb 18 09:04:00 PST x

I connected via minicom to AURIX and it shows version 1.03

So why I have a black screen on my DRIVE PX HDMI output. is there a way to fix this problem.

Thanks for you help and support

Qassab

Hello Qassab,

Could you please check your host machine environment with below doc?
I think the doc is useful.
Please download getting-started-with-drivepx2 file via below link.

And then could you please re-flash Tegra A/B? Thanks.

Hi Steve,

Thanks, I could recover the Tegra (A/B) and now the GUI interface is working. I have few question?
I only executed the commands that are related to Tegra flash section. Do I have to install all the libraries and application manually on Drivr PX. I noticed that the files names on NVONLINE are different files name that is in presentation that you refereed me to. It is for an older version. for example there is no file called “nv-gie-repo-ubuntu1404-*_amd64.deb” on NVONLINE for Target. the only Tensor related file in NVONLINE for Tegra is .run file Not .deb.

I tried to compile some of samples in ~/NVIDIA_CUDA-8.0_Samples$ but i got this message /usr/bin/ld: cannot find -lnvcuvid

missing libraries ?

here is my host PC linux version and gcc information
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/4.8/lto-wrapper
Target: x86_64-linux-gnu
gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04.3)

Linux WavesPX1 3.18.0-031800-generic #201412071935 SMP Mon Dec 8 00:36:34 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

I’m not using any Nvidia driver now (native graphics) I tried to used GTX version 378 driver but I could not run Driveinstall ( it was unstable) what version nvidia GTX driver is recommend to work with Drive PX SDK. I have GTX 980 TI

I want to install DriveWork and without the proper libs it wont work

If the Driveinstall has issues with installing the libraries, I’ll to do fresh ubuntu 14.04.3 and Install the SDK ( I dont have access to PDK) manually

Thanks for your time and support

Qassab

Hello Qassab,

Could you please add below in DPX2?

$gedit ~/.bashrc
export PATH=/usr/local/cuda-8.0/bin/:$PATH
export LD_LIBRARY_PATH=/usr/local/cuda/targets/aarch64-linux/lib:$LD_LIBRARY_PATH

source ~/.bashrc nvcc --version

Maybe you can check CUDA version via the command.
And then please re-compile CUDA samples. Thanks.