Geforce GTX Titan: no CUDA-capable device is detected (error 38)

I get this error with all tested CUDA programs (e.g., the toolkit samples).
The error is very strange considering that the Gefore Titan should support all aspects of CUDA.
My platform it is a normal Desktop PC and I am not using remote desktop.

My system configuration:
Windows 7 (Desktop), the latest NVIDIA driver (320.39), CUDA 5.5.

I tried with several versions of CUDA, however for the versions prior to 5.5 (5.0, 4.2) there was an installation error (the driver could not be installed).

Your help is greatly appreciated, I am really stuck here.

greetings,
Oliver

Hi,
Titan is a very latest cards and i don’t think the old versions of driver prior to 5.5(5.0, 4.2) will support it.but CUDA 5.5 should be work.

Have you installed driver 320.57 coming with CUDA 5.5?

Thank you for your quick reply. Installing the 320.57 driver coming with Cuda 5.5 does not help either. Still no cuda device is available (although all necessary files have apparently been installed in the right places). I fear that support for the Titan might be missing in Cuda 5.5.

I have the same problem with GTX Titan.

I work with Windows 7 Professional.

When I installed the CUDA 5.5 an error appeared and I can not finish the installation.

What do I do?

Thanks.

Hi,
I try the latest whql driver on my Windows 7 OS,it works well for Titan.

http://www.nvidia.com/object/win8-win7-winvista-32bit-320.49-whql-driver.html

After installing driver finished,you can install CUDA 5.5 package by choosing custom installation option without the 320.57 driver selected.then the installation will be finished successfully.after that,you can get CUDA 5.5 works.