GTX 770 and Nvidia drivers issues

EDIT: Solved! I had to disable internal graphics in the bios. It was messing with everything nvidia related.


Hi. I’ve upgraded to a GTX 770 and my attempts to get the drivers working on Lubuntu/Ubuntu have been unsuccesful so far, so I’m looking for a little bit of help.

So far I tried to install them in two ways, both times in a fresh Lubuntu install:
-manual installation of the 319.32 driver using the official release from the nvidia website
-using the xorg-edgers ppa to install the 319.23 driver

Both attempts have been unsuccessful in the same way and show the same issue.

If I try to boot with my screen plugged into the GPU, right after grub I get a black screen with a blinking cursor, and nothing happens.

If I try to boot with my screen plugged into my motherboard, it boots properly, I assume that it uses my CPU’s graphic chipset (HD 4600)?

If I try to get into the NVIDIA X Server Settings, it displays an error:

You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run 'nvidia-xconfig' as root), and restart the X server.

So I ran the said command, and restarted X, but the same error keeps getting displayed. Here is a copy of my xorg.conf file, on pastebin:

Also, when I run

sudo cat /proc/modules |grep nvidia

It doesn’t print anything, whereas if I do

sudo cat /proc/modules |grep nouveau

I get some files displayed.

So would the issue be that the nouveau drivers are not properly blacklisted?
If I check the


file, it does contain blacklist nouveau. Full content of that file on pastebin:

I’m not a very experienced user, so I don’t really know what else to try. I really would like to get those drivers working properly. Any help will be greatly appreciated. If you have any question please ask.

Thank you.

Radoslaw Jurga

I got a similarly problem, multiples Black-screen after Windows 7 Pro. Logo. However, every 10th restart, the system went up and everything worked. After reinstalling multiple Nvidia drivers and even make the older driver GTX770 conform, the problem still existed.

My System is:

Asus A87z Pro & Gainward GTX770 Phantom, i4770 CPU and 32 GB RAM & Samsung SSD 256GB as boot device. Logitech G930 Headset.

For myself I found a workaround:

-) turned of the HD Audio of the MDB itself in Bios
-) turned the PCIe 16x from Auto to Gen2 in Bios

Now everything is fine. Think that the GTX770 can’t handle the Gen3 PCEe very well.

However, I didn’t try yet if I could connect external speakers with my system. Maybe I have to turn on the onboard HD Audio again, but for now it works.

Would like to read if it works for you too?


Same think with me, I try a lot of thing, fresh install, driver for card, m/b, realteak, better psu, C-state.
now ALL is up to date…

Finaly i found what is in conflict with my machine, i turn off onboard video in the bios.
everithing runs fine now! YAHOOOOOOO!