How can i get imu topic using ros2 in isaac sim?

I want to get the imu topic using ros2 in isaac sim.
I followed the tutorial (’ Multiple Robot ROS2 Navigation’) and can get the sensor topic(camera, lidar) using ros2.
But In action graph, i couldn’t find the imu nodes for getting imu topic.

By any chance, Is there any way to get the IMU topic using ros2?

My isaac sim version is “2022.1”.

Please let me know if anyone know…
Thank you!

I am facing almost the same question with you.
I would appreciate it if someone could tell me how to publish imu topic in action graph.
Thank you!!!

There will be a tutorial for this in the next release coming out mid August

1 Like

Thanks for you quick reply.
By carefully reading the document. I know that i can use omni.isaac.isaac_sensor to get imu date.
So I added a imu in my robot and saved it as a .usd. Then I tried to write a py to publish it as a ros imu topic.
But when i tried to run the ./ exts/omni.isaac.quadruped/omni/isaac/quadruped/robots/ in lch@lch:~/.local/share/ov/pkg/isaac_sim-2022.1.0$.
Error appears:
File “exts/omni.isaac.quadruped/omni/isaac/quadruped/robots/”, line 6, in
from omni.isaac.isaac_sensor import _isaac_sensor
File “/home/lch/.local/share/ov/pkg/isaac_sim-2022.1.0/exts/omni.isaac.isaac_sensor/omni/isaac/isaac_sensor/”, line 10, in
from .scripts.extension import *
File “/home/lch/.local/share/ov/pkg/isaac_sim-2022.1.0/exts/omni.isaac.isaac_sensor/omni/isaac/isaac_sensor/scripts/”, line 15, in
from .menu import IsaacSensorMenu
File “/home/lch/.local/share/ov/pkg/isaac_sim-2022.1.0/exts/omni.isaac.isaac_sensor/omni/isaac/isaac_sensor/scripts/”, line 13, in
from pxr import Sdf, UsdGeom, Gf
File “/home/lch/.local/share/ov/pkg/isaac_sim-2022.1.0/kit/extscore/omni.usd.libs/pxr/Sdf/”, line 24, in
from . import _sdf
ImportError: /home/lch/.local/share/ov/pkg/isaac_sim-2022.1.0/kit/extscore/omni.usd.libs/bin/ undefined symbol: _ZN32pxrInternal_v0_20__pxrReserved__18Tf_PostErrorHelperERKNS_13TfCallContextENS_16TfDiagnosticTypeEPKcz
There was an error running python.
I really don’t know how to fix it. I would highly appreciate it if you could help me.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

@1300802319 can you try running that command in a terminal that does not have ROS sourced and see if it works

@1300802319 , did you try running the command as directed in previous comment?