How to docker save 4gb container if i have only 1 gb left/How to docker save container directly on the external drive

Hello.I have only 1gb left on my device and i need to export my 4gb docker container.
(I am going to do that by the commands docker save and docker load).How can i do that ?

I tried to change the root directory (for the docker save command) by the command:

sudo dockerd -g /mnt/path/to/docker/dir , but for some reason i couldnt do that.Even with sudo permission was denied.

Hi,

Please try the below workaround:

Thanks.

Unfortunatelly it didnt help.I still have the same (with a sudo dockerd -g /mnt/path/to/docker/dir command) permission problem:


Full log is here:
log11 (2).txt (43.7 KB)

How can i solve the “operaion not permitted” error ?

Besides this, this operaiton destroyed my docker structure, and now i cant use dockers anymore:

atlas@atlas-desktop:~$ sudo service docker run
Usage: service docker {start|stop|restart|status}
atlas@atlas-desktop:~$ sudo docker images -a
Cannot connect to the Docker daemon at
atlas@atlas-desktop:~$ cd /home/atlas/jetson-inference
atlas@atlas-desktop:~/jetson-inference$ docker/run.sh -c trtpose2 —volume /home/atlas/Desktop/Jupiter1:/home/atlas/jetson-inference
ARCH: aarch64
reading L4T version from /etc/nv_tegra_release
L4T BSP Version: L4T R32.7.4
localuser:root being added to access control list
CONTAINER_IMAGE: trtpose2
DATA_VOLUME: —volume /home/atlas/jetson-inference/data:/jetson-inference/data —volume /home/atlas/jetson-inference/python/training/classification/data:/jetson-inference/python/training/classification/data —volume /home/atlas/jetson-inference/python/training/classification/models:/jetson-inference/python/training/classification/models —volume /home/atlas/jetson-inference/python/training/detection/ssd/data:/jetson-inference/python/training/detection/ssd/data —volume /home/atlas/jetson-inference/python/training/detection/ssd/models:/jetson-inference/python/training/detection/ssd/models —volume /home/atlas/jetson-inference/python/www/recognizer/data:/jetson-inference/python/www/recognizer/data
USER_VOLUME: —volume /home/atlas/Desktop/Jupiter1:/home/atlas/jetson-inference
DISPLAY_DEVICE: -e DISPLAY=:0 -v /tmp/.X11-unix/:/tmp/.X11-unix
docker: Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?.
See ‘docker run —help’.

Is it possible to fix this without backup ?

Hi,

Could you check the docker status after stopping the service?

$ service docker stop
$ sudo systemctl status docker.service

Thanks.

Hello.I used backup to fix broken docker structure and checked the docker status:


log1.txt (110.7 KB)

Hi,

It looks like the docker is stopped successfully.
Then could you try to restart it again?

It’s expected to work.

sudo systemctl restart docker.service

Thanks.

Hello.Yes, it works. I used backup to fix broken docker structure.So, i dont have any problems (except the permission error) with the work of the docker.

log (4).txt (3.6 KB)

But i still need to docker save container directly on the external drive (because i dont have enough space to save it on my device).And, unfortunatelly, i still cant do this, because of, permission error:

Thanks.

Hi,

Is it possible to re-pull the image on the external storage directly?
Does it work?

Thanks.

Hi.This method doesnt work, because of the permission error: eMMC storage is getting filled and not able to run other applications by using docker containers - #5 by AastaLLL

sudo dockerd -g /mnt/path/to/docker/dir doesnt work too, because of the same error.

Could you give me other method of the re-pull ?

Sollution can be found here : Can i delete . cache file on my jetson nano to increase available space? - #16 by andres.artavia

Thanks.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.