How to flash Jetson AGX ORIN Developer Kit using Linux_for_Tegra/tools/kernel_flash/

Hello, my host PC is a Ubuntu 20.04. Recall:
I download and extract both released Jetson Linux 34.1 Drivers on my Ubuntu host.
I power up the Jetson AGX Orin and then plugged its USB C cable to Ubuntu host PC. I also check that Jetson ORIN has interface while Ubuntu host has since its needed for initrd flash to run.
I also make sure from my Ubuntu host that these commands are executed:
sudo systemctl stop udisks2.service
sudo apt install libxml2-utils simg2img abootimg sshpass
I executed command below from my host to setup my USB
sudo parted /dev/sd<x> mklabel gpt
sudo parted /dev/sd<x> mkpart APP 0GB 32GB
sudo mkfs.ext4 /dev/sd<x>1
I update on ./tools/kernel_flash/flash_l4t_t234_nvme.xml sector_size and num_sectors to fit my USB device specs after executing
cat /sys/block/sd<x>/queue/hw_sector_size
cat /sys/block/sd<x>/size
First I plugged USB device on Ubuntu host and run command
sudo ./tools/kernel_flash/ --external-device sd<x>1 \
-c ./tools/kernel_flash/flash_l4t_t234_nvme.xml -S 16GiB --showlogs jetson-agx-orin-devkit sd1
But the flash was not successful (nothing is written on my USB). At the end it is shown
Cleaning up…
Finish generating flash package.
No devices to flash
I also tried sudo ./tools/kernel_flash/ --external-device sd<x> \
-c ./tools/kernel_flash/flash_l4t_t234_nvme.xml -S 16GiB --showlogs jetson-agx-orin-devkit sd<x>
And I tried
sudo ./tools/kernel_flash/ --external-device sd<x> \
-c ./tools/kernel_flash/flash_l4t_t234_nvme.xml -S 16GiB --showlogs jetson-agx-orin-devkit sd<x>1
But nothing seems to work
Secondly I try to plugged USB device on the Jetson Orin and try the flashing as above. But I cannot make it work.
Here I share flashing log Thank you
flash_log.txt (110.9 KB)

1 Like

What is “sd1”? I think the default device name should be something like sda1.

Instead of writing sda1, I try to write sd<x>1 but it was not taken correctly. Where x could be a, b and so on.

You can try to boot from emmc, check what is the device node for usb.

After booting from emmc
blkid command shows:
/dev/sda1: UUID=“456668db-7f68-48e1-93c5-49227ff1a2b8” TYPE=“ext4” PARTLABEL=“APP” PARTUUID=“c478a58e-bd84-4ddd-89be-801d5c22cebb”
While fdisk -l shows:
Disk /dev/sda: 57.31 GiB, 61530439680 bytes, 120176640 sectors
Disk model: SanDisk 3.2Gen1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: CD257E84-A933-4742-A149-3FE80F078C7E

Device Start End Sectors Size Type
/dev/sda1 2048 31250431 31248384 14.9G Linux filesystem

Recall ./tools/kernel_flash/flash_l4t_t234_nvme.xml header is set to:
<partition_layout version=“01.00.0000”>
<device type=“nvme” instance=“0” sector_size=“512” num_sectors=“120176640” >

@WayneWWW can you please confirm me that Jetson AGX Orin does not support flashing? Why am I asking? It is because while debugging I spot on log
initrd_flash_debug.txt (4.1 KB)
That it finds vendor=0955 and product=7020. But 7020 product is missing on script
From host I can confirm product 0955:7020 which is specific to JETSON AGX ORIN by executing
Bus 001 Device 050: ID 0955:7020 NVIDIA Corp. L4T (Linux for Tegra) running on Tegra
What do you suggest as a fix?

Are you able to use sdkmanager to flash nvme on your board?

And 0955:7020 is not the number of AGX Orin. It only indicates your Orin is not in recovery mode.

When the board is in recovery mode and in device mode after the OS is on, the number you see in lsusb will be different.

If you see “AGX concord” in your script, then it is Orin.

1 Like

If sdkm cannot flash, then it will be fixed in next release. JP5.0 DP is not stable so lots of features are not ready.

@WayneWWW I have not a nvme disk with me. Still I was able to use sdkm to flash default EMMC. But I was not able to flash USB

I notice such message during USB flash
14:12:04.883 - error: NV_L4T_FLASH_ORIN_WITH_OS_IMAGE_COMP@JETSON_AGX_ORIN_TARGETS: tar: Write checkpoint 10000
All I know is USB was partitioned to 12 parts and its contents is unknown

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.