How to improve tessellation quality on imported models?

Hello, I just imported an USD file I exported from Fusion360 and as with FBX I don’t have much control during the export on the tessellation quality, can I increase this directly in Create ? Or is it better to use Step files from Fusion360 and what’s the best setting ? thanks

You can try the Refinement settings in the Geometry section of the model.

1 Like

Thanks I tried refinement settings but that didn’t do the trick, I think it has to be done on import, I see that increasing these setting helps but I don’t see much info on what’s the best setting for my cad files. Would be great to have some settings there like low, medium or high quality etc. thanks

There seems to be a bug somewhere as increasing the settings doesn’t do much, in some cases updating the settings seem to give better results but it’s not normal behaviour I think I’m going to make a report about it.

Refinement does the trick for me, we need to use the Catmull-Clack method.

1 Like

thanks, I tried that as well, I think it depends on the model imported, for now I prefer to use another tool to export the meshes correctly before importing to Create

Hello @HansVanEven! Could you send us a copy of the source file you are trying to import? I have have the dev team take a look at it to help give you some answers. You can send it to me here:

1 Like

thanks Wendy will send you the file later today, now that I’m using the localhost nucleus I did an import of a guitar body I’m working on in .step file and this time the import went very well, I only had some issues with sluggish interface that went away after relaunching Create but the model looked nice this time, maybe related to the nucleus server, I’ll do some more tests to see if it’s related to using Nucleus or not

I think I found the issue, it depends on how you import it via file > import it works nice, but if you select Open Cad files as USD in new stage the model looks jagged, not smooth, I sent the file to you so you can test.