How to update Boost in Jetson agx Orin?

Hello all,

I am using Jetson Agx Orin , with following configuration, attached in the screen shot.
I am working on an Exoskeleton which is operated in CANOpen protocol and the packages for that is not suited with 1.71 boost present in the Jetson.

I want to update the boost to 1.75 + versions

(Note: I have tried manually to install the boost and added the path in bash.c but unfortunately there is no resource available in internet so far on this topic , on how to solve this issue).

Please help me on this issue
Thank you

Hi itscharan98,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack version in use?

Hello @KevinFFF
I am using the devkit , its running on 5.1.1

It seems the default version for boost is v1.71.

Have you tried to download boost v1.75 and build/install manually?
You could refer to the following instruction from boost.
Boost Getting Started on Unix Variants - 1.75.0

yes , i have tried manually installing the boost and adding the library path in bash.c file but nothing seems to work.
also the 1.71 boost is available in the lib>aarch linux 64 folder where the permisiions cannot be changed to update the boost .

i dont know any other way as of now

You could refer to the following link and the steps to install boost 1.75.
How to install Boost C++ library on Ubuntu 20.04 or 22.04 (

Step1: Download Boost 1.75

Step2: Extract and enter directory
  tar --bzip2 -xf boost_1_75_0.tar.bz2
  cd boost_1_75_0/

Step3: Install neccesary packages
  sudo apt-get install build-essential g++ python3-dev autotools-dev libicu-dev libbz2-dev libboost-all-dev

Step4: Setup bootstrap for b2
  sudo ./ --prefix=/usr/
  sudo ./ --prefix=/usr/ --with-toolset=gcc --without-libraries=python

Step5: Install Boost
  sudo ./b2
  sudo ./b2 install

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.