Inquire about JetPack 3.2

Recently, I bought a Jetson TX2 for development. It was my initial setup for Jetson TX2, and my host computer used Ubuntu 16.04 (x64). When I run “”, I encounted the following error:

Error occurs during installation.
Return Code: 1
2017/12/23 22:09:36 dialing:dial tcp getsockopt: connection refused

Does anyone can help me solve this problem?
In addtion, under the same environment, I run “”, and it was no problem, and I can install successfully.

JetPack 3.2 is a “pre-release”…it is for testing only. JetPack 3.1 is the current production release. This may of course have nothing to do with the error, but since 3.1 works for you it tends to imply a bug with 3.2 if you didn’t run out of disk space.

FYI, getsockopt is a network error. Connection refused typically means some part of the network is not set up for that operation, e.g., a web browser trying to connect to a non-existent web server would cause this (that’s just a contrived example for illustration). Sometimes a firewall will do this. If you use a VM, then perhaps networking wasn’t passed through…or if you have a router not controlled by you, perhaps it needs a MAC address to be allowed (if your PC acts as a router, then there may be configuration to only accept if MAC address is known).

Note that the address is on your local computer, and wants a TCP connection to port 33335, which in turn implies something JetPack wants to provide (the Jetson wants to consume) via a network connection. Perhaps JetPack was not given permission (it would require root permission, and any firewall would have to not get in the way). During operation JetPack is intended to be started as a regular user, and then your password is prompted for later in order for JetPack to use sudo for root permissions. If the disk was full some network connections will fail (check “df -H”), and if your user is not an admin user (allowed to use sudo), then this error is possible.

Hi linuxdev:

Thank you so much for you reply.

At first, let me introduce my setup environment:
(1) About the host PC, it installed ubuntu 16.04 directly, and it was not a VM; In addition, I did not install any firewall.
(2) A router was connected to internet, and connected the host PC and Jetson TX2, each local IP of them are, and Also, they can ping each other.
(3) I used commmand “./” to run (no sudo), because if I command “sudo -s” to login as root, but when the commmand “./” was run, the error windows containing “error: please run jetpack as a non-elevated user. when root access is needed, the installer will prompt you.” occured.
(4) “df -H” has been confirmed, and output are as followings:

Filesystem Size Used Avail Use% Mounted on
udev 8.4G 0 8.4G 0% /dev
tmpfs 1.7G 11M 1.7G 1% /run
/dev/mapper/ubuntu–vg-root 487G 92G 370G 20% /
tmpfs 8.4G 549M 7.9G 7% /dev/shm
tmpfs 5.3M 4.1k 5.3M 1% /run/lock
tmpfs 8.4G 0 8.4G 0% /sys/fs/cgroup
/dev/nvme0n1p1 495M 202M 268M 43% /boot
tmpfs 1.7G 66k 1.7G 1% /run/user/1000

Anyway, it seems JetPack 3.1 had been installed in Jetson TX2 successfully. But I wonder how can I confirm the version of JetPack installed in Jetson TX2 ?

If you’ve ever run JetPack with sudo, then some files will exist with root-only permission. You probably need to delete everything under the JetPack3.2 directory (which itself probably requires sudo) and start again without sudo. This would cause some failure conditions. The easiest way to be sure is simply re-running from an empty directory.

JetPack itself does not install to the Jetson, it’s L4T which installs (JetPack is a front end to the package). The L4T version is found from:

head -n 1 /etc/nv_tegra_release

The most recent L4T of JetPack3.1 is R28.1. So anything newer than R28.1 would imply JetPack3.2 pre-release was used.

Hardware setup looks ok, but I am assuming the connection from Jetson to router is wired…if this is WiFi it will fail (host can be WiFi, it’s just the Jetson which needs wired).

I am thinking perhaps it is possible the getsockopt failure could be permissions, e.g., lack of the correct password when required, or having a file owned by root which is from a non-root step…the previous comment about starting in an empty directory without sudo should guarantee success so far as permissions go (sometimes temporary files are used with networking).

I see. I will make a try.
Thank you for your advice.

I’m having exactly the same error on a new Ubuntu 16.04. I’m following the installation guide and my laptop is connected to mi home router using a wire. The Jetson TX2 is on and connected to the router also.
I’ve never use sudo for running the jetpack .run
I have nothing else installed in the Ubuntu.
I tried disabling the firewall but didn’t works.

Any idea?

Is it the getsockopt error? A log of the last paragraph of output would be useful. Note that network errors between host and Jetson are not related to flash…these are only for extra package installs. Network errors between PC and internet is a different issue since it can block (somewhat randomly) every various step.

A common question is whether the Ubuntu host is a VM or not…it sounds like it isn’t (which would be good), but I need to ask.

Hi linuxdev,

Thank you for your reply. Ubuntu host is a Dell laptop model Inspiron 5577. The error I getting is:

Error occurs during installation.
Return Code: 1
2018/01/21 17:29:26 dialing:dial tcp getsockopt: connection refused

I can ping and the firewall is disabled. My Jetson TX2 is connected but I don’t think this error is related with that.

It means it was expecting a program to be listening on port 33335, but the program wasn’t running (a firewall could do this too, but it is rather unlikely). You’d need to show more logging before that.

Is the Ubuntu installed directly on the hard disk without any virtualization? Were there any other errors? FYI, getsockopt might indicate a software addition or configuration failing, but this would not interfere with a flash stage.

I could finally install Jetpack 3.2. I tested Jetpack 3.1 and I got no error, so I try again with 3.2 but using the default Installation Directory and then it run ok. In the past I were using ~/Programs/nvidia as Installation Directory. Thank you very much for your help!

I found if your version is older than 3.1, you can upgrade to 3.1 at first. After that, you can upgrade from 3.1 to 3.2 successfully. If you upgrade from the older version to 3.2 directly, maybe you will encounter some problems.

I had this error. I got around it by:
mkdir /home/me/jetpack
chmod 7777 /home/me/jetpack
mv < file> /home/me/jetpack
cd /home/me/jetpack
./< file>

This works
Host was Ubuntu 16.04 running native

For me, just by placing the file in a specific folder. Going into that folder and running the command

bash ./

solved the problem