Installation of TensorFlow on Drive PX

Hi,

I’m having a really hard time to installing TensorFlow on Drive PX (the first one).

I’ve found other guides but those are for Jetson TK1 boards, and the Nvidias own instructions (http://www.nvidia.com/object/gpu-accelerated-applications-tensorflow-installation.html) doesn’t work. It fails around installation of Bazel via apt-get.

Are there any guides for Drive PX?

We were able to install it following this: https://github.com/jetsonhacks/installTensorFlowTX1/

0.12 worked for us and someone else got 1.0 working as well. Some of those patches may not need to be applied for 1.0/0.12 or you may need to do some searching in the files to apply it in the correct place.

Good luck!

Thanks for the link!
Now I’m stuck at building the tensorflow as it requires a lot of memory. I tried several different way to allocate memory, ‘fallocate’ which stops with error Operation not supported and with ‘dd’ I couldn’t activate the memory with ‘sudo swapon’ of function not implemented. Am I missing some package like L4T for Drive PX?

Hi iMighty,

When building TensorFlow, try to adjust your resource allocation parameters for “bazel build” to “–local_resources 8192,2.0,1.0”.

The memory configuration of DRIVE PX 2 is different from Jetson TX1’s.

Hi!

this install tutorial worked pretty good for me on Drive PX 2 and Linux 16.04:

@all how do you plan to use tensorflow with direct camera input?

Thanks for the link! But I’m still stuck at the memory allocation. fallocate gives me, “fallocate failed: Operation not supported” and I tried your solution nvok. For those that aren’t aware I’m running on a Drive PX ONE, fresly flashed.

Hi, we are trying to install tensorflow on PX2, it seems that instruction is for TX2. Do we need any more modification for PX2? Thanks.

Dear jimd96,

Could you refer to below link for DRIVE PX2 Deep Learning App Notes? Thanks.
“DRIVE PX2 Deep Learning App Notes” https://developer.nvidia.com/nvidia-drive-downloads

Hi,

I tried to install TensorFlow on Drive PX2 by following the link:

https://syed-ahmed.gitbooks.io/nvidia-jetson-tx2-recipes/content/first-question.html

Also, I adjust your resource allocation parameters for “bazel build” to “–local_resources 8192,2.0,1.0”. But it still does not work. The system always crashes at the halfway of installation. Could you help me with this situation?

Thanks

Hello,

has anyone a copy of the contens of the link given in the previous posts? (https://syed-ahmed.gitbooks.io/nvidia-jetson-tx2-recipes/content/first-question.html) The original source seems to be not available any more.

Thanks a lot!

Yes this would be helpful.

Does anyone still have the copy to the link stated above, or at least a way to install tensor flow right from the beginning on drive PX2 I have already tried multiple links related to the TX2/TX1/TK1 but all my efforts have been useless as of now. Also the link has become inaccessible at the moment.

It turns out there is a problem with Bazel, as far as I can see. I have already changed the --local_resources variable as stated above. Didn’t work out though. Thanks.

Dear mac2660,
Could you please refer the installation instructions on docker at https://developer.nvidia.com/driveworks/files/DRIVEPX2_AppNote_TensorFlow_1_0_Docker_Container

Hi SivaRamaKrishna

Thank you very much for your response. So I followed the instructions and I’ve got this error after I ran the script.

" Error 127, “Docker Login failed”, please resolve the issue or try again.
Please contact provider with log “drive_installer_0832d0b37cba2fdef1d2580483378fb2.log”.

======================================================
NGNG "

Kindly please help me out.

Thanks,
mac2660

Hi mac2660, hi SivaRamaKrishna,

we tried to use TensorFlow with the docker-container before some months and also failed. In this Forum at the Topic https://devtalk.nvidia.com/default/topic/1027904/?comment=5228522 I got the reply, that there is an issue with the DriveInstall 5.0 and this TensorFlow container.

@ShivaRamaKrishna: Is this already solved?

Best regards,
Felix

Dear felix.elrod,
The issue is addressed at https://devtalk.nvidia.com/default/topic/1031981/drive-hardware/official-support-to-installation-of-tensorflow-on-drive-px2/
Please refer to https://devtalk.nvidia.com/default/topic/1031300/jetson-tx2/tensorflow-1-7-wheel-with-jetpack-3-2- and see if it’s also suitable for PX2. https://github.com/peterlee0127/tensorflow-nvJetson

Worked for DrivePX2. Tensorflow 1.7 is successfully installed.

Hello,@serinvarghese, could you tell me how you installed the tensoflow1.7 on the DPX2? Did you use the conmand "pip install tensorflow-1.7.0-cp35-cp35m-linux_aarch64.whl “

Thanks a lot!

Yes that is how I installed it. Also you need to merge the two whl files. The links above give all the information regarding installation.

Regards,
Serin Varghese

Thanks, I also have installed it on DPX2.