Installing CUDA, CUDNN on TX2 and building tegra_multimedia_api codes


I have flashed jetpack 3.3 on TX2 but I can not see CUDA, CUDNN and Tegra Multimedia API.

But I can see cuda-l4t , cudnn , NVIDIA_CUDA-9.0_Samples and tegra_multimedia_api on my host machine instead of TX2 after flashing jetpack. So I copied all these folders to my TX2.

I did following things and got following erros :

  1. When I build the code present in tegra_multimedia_api folder, it gives following error.

Make in samples/00_video_decode
make[1]: Entering directory ‘/home/nvidia/tegra_multimedia_api/samples/00_video_decode’
Linking: video_decode
/usr/bin/ld: cannot find -lcudart
/usr/bin/ld: cannot find -lnvinfer
/usr/bin/ld: cannot find -lnvparsers
collect2: error: ld returned 1 exit status
Makefile:52: recipe for target ‘video_decode’ failed
make[1]: *** [video_decode] Error 1
make[1]: Leaving directory ‘/home/nvidia/tegra_multimedia_api/samples/00_video_decode’
Makefile:52: recipe for target ‘all’ failed
make: *** [all] Error 1

When I run command “nvcc --version”, it says “nvcc: command not found”.
That means CUDA is not installed.

2)Installing CUDA

I tried installing CUDA using the script “” present in “cuda-l4t” folder.
The script requires .deb file as input so I downloaded “cuda-repo-ubuntu1604-9-0-local_9.0.176-1_amd64.deb” from NVIDIA’s website.
(Link :

But when I run the script to install CUDA, it gives following error.
dpkg: warning: overriding problem because --force enabled:
dpkg: warning: package architecture (amd64) does not match system (arm64)

Could someone help me fix the above issues #1 and #2 ?

Thanks in advance.


Please install the package with JetPack installer directly.
The package you used is for x86 environment and it’s not going to work on Jetson.

Please try to reflash your device with JetPack again. (remove the incorrect package)
If the package cannot be installed when flashing, please run the JetPack again to install it without selecting OS.