Is there anyway to vacuum spheres up a pipe?

I created this scene, and the number of spheres is impressive watching it fall.

I am trying to think of interesting and / or possible ways to get the spheres back up to the top. I have tried elevators without too much success, so is something like those little tubes at a drive thru bank teller possible? Where air “sucks” up the spheres up a tube if they go underneath a pipe?

Thanks, open to ideas on how to go up, the falling works quite well.

Hmm, this sounds like fun! I posted this to the Physics team for some ideas!

1 Like

Hello @DataJuggler! Have you tried playing with force fields? We have a few which can “levitate” or “pull” the rigid body sphere back up in the Force Fields extension: Force Fields — Omniverse Extensions documentation

No. I think I saw that, but didn’t know what it was. I will read about that after work.


I tried the instructions of the force field. When I enabled the omni.usd.schema.forcefield and the other force field extension, restarted omniverse, and nothing worked right.

If I moved a sphere, it went back to its starting point. I tried to turn off this extension, and it was turned on and said Enabled, but greyed out (disabled), so I had to uninstall Create and Reinstall to fix it.

If you want I can record a video of this.

I just looked, after installing, reinstalling create, this option is still enabled, but not able to be turned off.

How do I turn this off?

Hi DJ,

there are several unfortunate things here that are tripping you up:

  • Enabling ForceFields will as a dependency also enable the PhysX FlatCache extension.
  • The PhysXFlatcache extension is an extension that improves perf for very large object counts in part by no longer updating any of the GUI elements or python scripting etc. So likely you are running into those missing capabilities causing trouble.
  • The ForceFields extension is likely also depending on the FF Schema.

So I think the way to revert this is to disable the FF extension entirely, and then the Flat Cache extension.

I find that I then also need to restart create for the FC induced behavior problems to go away.

I believe PhysX schema extensions all must be loaded due to USD related dependencies and they cannot just be unloaded, that is why they are listed in the “non-toggleable” group. I would not worry about it.


The Flat Cache Extension was not enabled when I went to look at it.

Does Create store which extensions are enabled in the Registry? An internal database or config file? If I can toggle it off and restart Create I would like to know how to do that please. Why uninstalling and reinstalling didn’t fix it seems like a glitch in your installer.

I wish the ‘Not Toggleable’ was rethought, as I want a way to turn things off if I try them and decide it isn’t working.