Isaac gym running example error 🥷 no work to do.Not connected to PVD.GPU Pipeline: enabled

Hi:
Recently, i tried to run example with"python play.py --task=anymal_c_flat", and got the message with this. And,the isaac gym window appears and then disappear.
For some reason i reinstalled my NVIDIA driver. I am new at siaac gym, and don’t know how to solve it successfully after trying .

(rlgpu) dingle@dingle-HP-Z840-Workstation:~/legged_gym/legged_gym/scripts$ python train.py --task=anymal_c_flat
Importing module 'gym_37' (/home/dingle/isaacgym/python/isaacgym/_bindings/linux-x86_64/gym_37.so)
Setting GYM_USD_PLUG_INFO_PATH to /home/dingle/isaacgym/python/isaacgym/_bindings/linux-x86_64/usd/plugInfo.json
PyTorch version 1.10.0+cu113
Device count 1
/home/dingle/isaacgym/python/isaacgym/_bindings/src/gymtorch
Using /home/dingle/.cache/torch_extensions/py37_cu113 as PyTorch extensions root...
Emitting ninja build file /home/dingle/.cache/torch_extensions/py37_cu113/gymtorch/build.ninja...
Building extension module gymtorch...
Allowing ninja to set a default number of workers... (overridable by setting the environment variable MAX_JOBS=N)
ninja: no work to do.
Loading extension module gymtorch...
Setting seed: 1
Not connected to PVD
+++ Using GPU PhysX
Physics Engine: PhysX
Physics Device: cuda:0
GPU Pipeline: enabled
Segmentation fault (core dumped)

here is my new NVIDIA driver information (nvidia-smi):

Thu May 26 16:31:07 2022       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 510.60.02    Driver Version: 510.60.02    CUDA Version: 11.6     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:04:00.0  On |                  N/A |
|  0%   54C    P8    48W / 400W |     78MiB / 12288MiB |      1%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A      1474      G   /usr/lib/xorg/Xorg                 74MiB |
+-----------------------------------------------------------------------------+

Thanks for every helps !

I remove my environment——rlgpu, and rebuild it. But when i run python 1080_balls_of_solitude.py, i got this

(rlgpu) dingle@dingle-HP-Z840-Workstation:~/isaacgym/python/examples$ python 1080_balls_of_solitude.py
Importing module 'gym_37' (/home/dingle/isaacgym/python/isaacgym/_bindings/linux-x86_64/gym_37.so)
Setting GYM_USD_PLUG_INFO_PATH to /home/dingle/isaacgym/python/isaacgym/_bindings/linux-x86_64/usd/plugInfo.json
WARNING: Forcing CPU pipeline.
Not connected to PVD
+++ Using GPU PhysX
Physics Engine: PhysX
Physics Device: cuda:0
GPU Pipeline: disabled
Segmentation fault (core dumped)

Actually, When i run “python play.py --task=anymal_c_flat --headless”,it works! But, now I cannot use issacgym with GUI mode.
When i do vulkan-info , and vk-cube,i got this.

(rlgpu) dingle@dingle-HP-Z840-Workstation:~/legged_gym/legged_gym/scripts$ vulkaninfo
ERROR: [Loader Message] Code 0 : libGLX_nvidia.so.0: cannot open shared object file: No such file or directory
ERROR: [Loader Message] Code 0 : loader_icd_scan: Failed loading library associated with ICD JSON libGLX_nvidia.so.0.Ignoring this JSON
ERROR: [Loader Message] Code 0 : vkCreateInstance: Found no drivers!
Cannot create Vulkan instance.
This problem is often caused by a faulty installation of the Vulkan driver or attempting to use a GPU that does not support Vulkan.
ERROR at /build/vulkan-tools-1.3.211.0~rc3-1lunarg18.04/vulkaninfo/vulkaninfo.h:665:vkCreateInstance failed with ERROR_INCOMPATIBLE_DRIVER

(rlgpu) dingle@dingle-HP-Z840-Workstation:~/legged_gym/legged_gym/scripts$ vkcube
vkEnumerateInstanceExtensionProperties failed to find the VK_KHR_surface extension.

Do you have a compatible Vulkan installable client driver (ICD) installed?
Please look at the Getting Started guide for additional information.

Is this the reason why I can’t use the GUI mode?