IsaacGym Setup: X Error of failed request: BadMatch

I need IsaacGym for a project and after having installed it I’m trying to run a few provided examples. However, when I run the command python 1080_balls_of_solitude.py, it starts running, launches an IsaacGym window, and instantly crashes. I want to run it on my laptop right now to get accustomed to IsaacGym, but I will be running any real simulations on a cluster later.

The error I’m getting is the following:

Importing module ‘gym_38’ (/home/user/isaac_ws/isaacgym/python/isaacgym/_bindings/linux-x86_64/gym_38.so)
Setting GYM_USD_PLUG_INFO_PATH to /home/user/isaac_ws/isaacgym/python/isaacgym/_bindings/linux-x86_64/usd/plugInfo.json
WARNING: Forcing CPU pipeline.
Not connected to PVD
+++ Using GPU PhysX
oPhysics Engine: PhysX
Physics Device: cuda:0
GPU Pipeline: disabled
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 149 ()
Minor opcode of failed request: 4
Serial number of failed request: 212
Current serial number in output stream: 233

I’m running this an on XPS 9500 2020 on Ubuntu 22.04 with a GTX 1650 Ti using driver 525.78.01 and CUDA version 12.0.

Any help would be appreciated.

1 Like

Hi,
have you solved this problem? I have the same issue. Thank you

Hello,

Unfortunately I found no solution to this issue, and ended up installing Ubuntu 20.04 on a separate partition.

Thank you. Good to know it works fine on Ubuntu 20.04

did it work on ubuntu 20?

Yes, it did for me.

Thank you, it works well now.

@mheyrman

Are you able to view the rendering for the simulation?
Asking cuz even I have a GTX 1650 Ti powered laptop and the Isaac Sim window keeps saying RTX loading and doesn’t render anything. ( Expected considering the min requirements include a RTX :( )

Just wanted to ask if were able to figure a way around this and make it work ?

Hello,

Yes, I am using an XPS 15 with a 1650Ti and if I’m running in Ubuntu 20.04 I have no issues rendering(in 22.04 it would not work). You may be missing a dependency somewhere or don’t have your GPU enable? Try the command nvidia-smi to check if you’re using your Nvidia GPU or integrated graphics.

I had the same issue. The root problem is that Vulkan uses Intel graphics by default instead of my NVIDIA GPU.

export VK_ICD_FILENAMES="/usr/share/vulkan/icd.d/nvidia_icd.json"

This should solve the issue. I found the answer on this thread: Invalid pixelmap or window parameter · Issue #2232 · carla-simulator/carla · GitHub

3 Likes

@arjunb
Thank you! It works!