Isaac Sim 2020.2.2 container fails to start on AWS

I followed the guidelines on how to deploy Isaac Sim on AWS EC2. And everything worked just fine. But after I stopped EC2 instance and started it again the container fails to start:

$ sudo docker run --gpus all -e “ACCEPT_EULA=Y” --rm -p 47995-48012:47995-48012/udp -p 47995-48012:47995-48012/tcp -p 49000-49007:49000-49007/tcp -p 49000-49007:49000-49007/udp nvcr.io/nvidia/isaac-sim:2020.2.2_ea

docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused “process_linux.go:449: container init caused “process_linux.go:432: running prestart hook 0 caused \“error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: initialization error: nvml error: driver not loaded\\n\”””: unknown.

Hi. Please show the output of nvidia-smi.
Also, is there any other containers running? Try sudo docker ps.

.

docker ps
nothing is running

nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

But it was working. The only thing I have done - is stopped and started a AWS instance

That is odd. Maybe try a sudo apt-get update then reboot?
Next, you could try reinstalling the drivers. Please try this version 455.
https://www.nvidia.com/Download/driverResults.aspx/166883/en-us

1 Like

Thank you for very quick support. Will try

1 Like

Reinstalling the drivers (version 450 - the same version) solved the problem

1 Like