Isaacsim2022.1 set viewport render resolution in omni.graph

I use the omnigraph to create a camera , attach the camera to viewport, and set the render resolution, use camera helper to publish ros date of camera. but when I run the sim, it results in carsh. I really don‘t konw why ?

hers is my omnigraph of camera and the isaacsim app log containing the crash report:


kit_20220613_001758.log (6.3 MB)
and my machine’s GPU is 3070ti , is Is my graphics card underpowered? i am really confused , really thanks if you could help me !

@qwan

I always meet the core dump of Not enough GPU memory because of multi camera , and how should i avoid it ?
MY GPU is 3070ti

I have set the FPS LIMIT on and fps limit = 30 from the viewport settings . It works now, but the ros publisher rate fall to less than 10hz . How should I increase the camere helper publisher rate and avoid crash because of GPU memery not enough ? It seems like the new isaacsim2022.1 need more GPU memory than old version . Thanks if you could help me.

@fzg7919 are you creating a second viewport, or trying to resize the existing main viewport?
Does the issue occur on a simple/empty scene?

yes if i declease the render resolution, i runs normally.
and the logs shows isaacsim crash because of insufficient memory ,maybe i set too high resolution and my GPU is not able to run it

can you run watch nvidia-smi in a separate terminal and confirm if that is the case?
GPU memory usage will also depend on the complexity of the scene and the number/size of textures in it.