Issue flashing TX2 with Jetpack 3.2

I’m having issues flashing my TX2 with jetpack. I have followed your tutorial to the letter however when i get to the part where i need to put the jetson to recovery mode, I put it as instructed and check it is available when doing lsusb. But i still get a message saying it failed to flash.
Also, when I put the TX2 to recovery mode the usb icon shows (L4T) which contains a text file about configuring the ip address and I lose internet connection.
I really need help solving this issue.

Are you using USB cable connected to mini port at Jetson and Ubuntu 16 at Host computer from that you are trying to flash? If yes, I would delete Jetpack folder, from the host computer, downloaded it again and try flashing again. What if you use more recent release of Jetpack [3.3]?

Yes,I am using the original Nvidia Usb cable as well. Following your advice I have deleted Jetpack and tried installing again but still same issue.

what is the version of Jetpack you used: 3.2 or 3.3 ?

I have tried 3.3 as well with the same result, basically whenever I put the TX2 to recovery mode and it’s connected via usb cable to the host the usb icon pops up and I lose internet connection ( it shows the host is looking for some sort of connection).

Hi nemomilgram,

Have you resolved the problem and flashed the TX2 successfully?