Issue when exporting Animated Point Cache USD and opening it in Unreal Engine (UE 4.27)

Hello :)

This is a question by my colleague who’s a rigger. He had a maya file with an animated skeleton mesh opened, and he clicked the “Export to USD” button on the Omniverse shelf and exported a USD animation file using the option “animated point cache.” This USD file, when opened in Omniverse Create, opens and moves well, but when opened in Unreal Engine 4.27, the file opens but it doesn’t move at all. He tried using sequencers and other methods but haven’t found a solution. Does UE 4.27 not support Animated Point Cache USD or is there a step we’re missing?

In addition, he tried opening the same Animated Point Cache USD in Omniverse Create and UE 4.27, and activated the live sync function. Then, he played the USD in Create, hoping the live sync function will work and make the mesh move in UE as well but the file still didn’t move in UE.

Further explanation on this topic would be much appreciated.
Thank you in advance.

A couple things:

  • The Unreal Connector doesn’t import animated point caches. It will import skeletal mesh animations and timesampled, non-vertex animated prims.
  • There is no synchronization of timelines between Unreal and Create. At the moment we disable live sync when editing imported timesampled data in the Level Sequencer because we aren’t able to support it very well.
1 Like