Issues when connecting more than six cameras on Xavier AGX

Hi all,

I am currently having a similar issue to the one on this post. I am trying to connect 16 cameras using the D3 expansion board.

The error seems to be related to Argus. I am able to capture from v4l2-ctl but I cannot from GStreamer nvarguscamerasrc. The error is the following:

nvidia@linux:~$ gst-launch-1.0 nvarguscamerasrc sensor-id=8 ! fakesink
Setting pipeline to PAUSED ...
Pipeline is live and does not need PREROLL ...
Setting pipeline to PLAYING ...
New clock: GstSystemClock
Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:645 No cameras available

(gst-launch-1.0:15432): GStreamer-CRITICAL **: 11:25:49.959: gst_mini_object_set_qdata: assertion 'object != NULL' failed
Got EOS from element "pipeline0".
Execution ended after 0:00:00.337293761
Setting pipeline to PAUSED ...
Setting pipeline to READY ...
Setting pipeline to NULL ...
Freeing pipeline ...
(Argus) Error EndOfFile: Unexpected error in reading socket (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 266)
(Argus) Error EndOfFile: Receive worker failure, notifying 1 waiting threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 340)
(Argus) Error InvalidState: Argus client is exiting with 1 outstanding client threads (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadCore(), line 357)
(Argus) Error EndOfFile: Receiving thread terminated with error (in src/rpc/socket/client/ClientSocketManager.cpp, function recvThreadWrapper(), line 368)
(Argus) Error EndOfFile: Client thread received an error from socket (in src/rpc/socket/client/ClientSocketManager.cpp, function send(), line 145)
(Argus) Error EndOfFile:  (propagating from src/rpc/socket/client/SocketClientDispatch.cpp, function dispatch(), line 87)

So far, I have tried some configurations which are:

  • Connecting one camera: when connecting the camera in any port from 0 to 7, all seems to work. From 8 to 15, I cannot capture.
  • Connecting multiple cameras in ports from 0 to 7 works as well. From 8 to 15, it does not work.
  • When I connect some cameras to ports 0 to 7 and other ones to ports 8 to 15, I can capture from none of them.

This issue appears after trying to upgrade from Jetpack 4.4 to Jetpack 4.5.1. In the former version, it worked fine, but the upgrade crashed. I saw that @diego.chaverri had a similar issue to this one (I would say the same issue). Is it possible to get the binaries or a fix for the Jetson Xavier AGX (Jetpack 4.5.1)?

Please, if you need more information, let me know.

Best regards,

Please upgrade to J4.6 and apply below patch for this knowing regression issue.

Hi @ShaneCCC

For compatibility reasons, upgrading to JP 4.6 is unsuitable for us. Could you help us with a solution for JP 4.5.1?

Best regards,

How about stay on J4.4?

Thanks for the quick answer.

Unfortunately, it does not work for us either. The customer seems to be stuck in JP 4.5.1.

hello luis.leon,

please check the attachment for verification, Topic196358_Nov29.7z (693.0 KB)

Thanks, it seems to fix the issue.

Can we know about the differences between these binaries and the ones in Jetpack 4.5.1? It is a matter of explaining what is happening.

It’s code regression cause the problem on J4.5.x and J4.6 should without problem in future release.

1 Like

you’ll see Invalid sensor placement is set. failure if you’re having camera use-case with more than 6 cameras,
it’s pre-built binary update to treat this failure as harmless,
such as…

those changes are not yet integrate to the release-32 code-line, they’re actually workarounds and we’re investigate proper solutions.

Thanks for the information.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.