Issues with oem config using JetPack 4.5.1


I have been automating the install process using the response file method. Flashing succeeds but the following issues occur when using the terminal to go through the oem configuration.

  1. When connecting to the serial port (/dev/ttyACM0 in my case) using screen OR minicom, I sometimes get a “Welcome” screen and sometimes it proceeds straight to accepting the user license agreement. I am using an expect script to automate the config and the inconsistent behavior of the setup screens is throwing things off.

-Is this a known issue? Is there something more reliable than screen or minicom? Is using expect to send the correct responses the right approach?

  1. I have tried using the script that disables oem configuration but it does not work. I have ran the script after downloading the necessary image files that gets saved in JetPack_4.5.1_Linux_JETSON_AGX_XAVIER but before flashing, which creates the JetPack_4.5.1_Linux_JETSON_AGX_XAVIER_TARGETS directory. After this method did not work, I tried the script in the newly created JetPack_4.5.1_Linux_JETSON_AGX_XAVIER_TARGETS directory. This also did not work.

Each time I ran the script it succeeded.

-Does this script work for JetPack 4.5.1? Am running the script in the right place?

Thank you in advance for your help.

Sorry that I cannot understand your exact problem for (1). Better sharing some photo for this case.

And for (2), we don’t have any official script to skip oem-config, thus, please indicate what script you are using.

Hi Wayne,

Thanks for the quick reply

I am using the script you posted here:

I’ve followed the steps and when I reflash, setup is still required over /dev/ttyACM0.

Here is the install flow:
1.Start fresh - uninstall JetPack using sdkmanager gui
2. run sdkmanager --cli install --responsefile response_file/sdkm_responsefile_jetson_P2888-0001.ini
— in the response file I skip flashing as to just download the JetPack files without flashing
3. run sudo ./ -u username -p password inside of the image/JetPack_4.5.1_Linux_JETSON_AGX_XAVIER/Linux_for_Tegra folder – the script finishes successfully
4. run sdkmanager --cli install --responsefile response_file/sdkm_responsefile_jetson_P2888-0001.ini
— this time flashing is performed
Note: the flashing step creates new directory image/JetPack_4.5.1_Linux_JETSON_AGX_XAVIER_TARGETS /Linux_for_Tegra. I assume this directory and rootfs was created with the default user I made but the oem configuration is still required.

Do those steps sound correct?

  1. I don’t guarantee that script will still work in every release. That is just a debug tool.

  2. After you configure the script inside Linux_for_Tegra, please do not run sdkmanager again. Just directly use to flash the board. If you never tried it before, check the quick start guide on our download center to know how to use it.

Thank you, I confirmed this does work using your steps i.e. using

It does not work using the response file method.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.