Jetpack 4.5 headless install: no oem-config on /dev/ttyACM0

Just attempted to updated my AGX developer kit from Jetpack 4.4.x to 4.5. via the SDK manager under Ubuntu 18.04. Everything went well with flashing the OS image, until it was time to run oem-config. I am running headless and unable to put a display on the unit; in the past I was able to run config from the command line on the virtual serial port /dev/ttyACM0

In this case there is no content on /dev/ttyACM0. Connecting to the serial port I see a good set of boot messages, ending in :

[ 11.130138] Please complete system configuration setup on the serial port provided by Jetson's USB device mode connection. e.g. /dev/ttyACMx where x can 0, 1, 2 etc.

Any chance oem-config / tty is not properly being setup on /dev/ttyACMx in this version of Jetpack?

After reboot, I get the virtual disk (L4T-README) and the network connection. I can ping, and can connect to /dev/ttyACM0, but no data on that virtual serial port.

hello amarburg,

may I know what’s your step to update the release image to JetPack-4.5, are you running Over-The-Air Updates?
is it possible to perform a whole image flash with NVIDIA SDK Manager to reproduce the issue.

I tried it twice, both times with SDK manager. Once was the “automatic” method where you give it the IP address/username/password of the existing installation and it puts the Jetson into recovery mode over SSH, then again where I put the unit in recovery mode using the recovery button.

In both cases the install to flash seemed to work (no error messages in SDK manager, reasonable stuff on the ttyUSBx console). But the same end result – no oem-config or login on ttyACM0

hello amarburg,

are you able to enable oem-config manually on a flash drive,
for example, Reconfiguring a Jetson Device with oem-config.

You mean as per “To re-enable oem-config manually on a flash drive”? I don’t have a second AGX to rebuild a flash drive.

If I need to, the simplest course will be to hook up a monitor and do the standard setup. It is still inconvenient, but possible.

hello amarburg,

we had confirmed Headless Mode Flow in with JetPack-4.5 works normally.

could you please share your steps in detail;
you may also take a snapshot to indicate what’s the actual failure you’d seen,

Hm, I tried it again from “manual recovery” (pressing recovery button) and got oem_config this time … so I guess things are OK?

hello amarburg,

the software process doing the same. you might have some hardware connection issue previously.
let’s close this thread since you’d confirm oem_config works. thanks

1 Like