Issues with user accounts on TX2


I’m experiencing issues with creating additional standard users on TX2. After creating a new user account, I log in into the account. But, the desktop does not start and ubuntu throws an error saying “Ubuntu experienced an internal error”.

I’ve tried reflashing the Jetson, but the issue still persists. I’m new to Jetson TX2, please let me know how to resolve this issue.


Try adding the user to the group “video”, e.g.:

sudo usermod the_new_user_name -a -G video

Thanks for the suggestion. I tried adding user to video group but I still get the same error.

If you log in via ssh or serial console as user nvidia or ubuntu, and monitor “dmesg --follow”, and also “sudo tail -f /var/log/Xorg.0.log”, and then attempt a login with the other user, what shows up?

I had changed the nvidia jetson kernel configuration and some other nvidia-specific files as I had to enable some ports. After resetting some of this to default, your solution of adding the user to the video group worked. Thanks for the help linuxdev

FYI, some of that is related to files verified from “sha1sum -c /etc/nv_tegra_release”. So long as those files remain intact things should be ok.

I am having exactly the same issue, do you mind giving more details on you fixed it ?

Did you add your new user to group “video”?

sudo usermod the_new_user_name -a -G video

also, if you run

id nvidia

You’ll be able to see all of the groups that the nvidia user is a member.

you can then add the other one that you need as well like the sound, dialout, etc.

sudo usermod -Ga <<group>> <<username>>